summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-26 12:14:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-26 12:49:08 +0100
commit34588839f4fb5889eb9d1f2de53efd361506e8c4 (patch)
treefa249d564e0d59107d170b42381b347c83a54f9a
parentmedia-libs/libiptcdata: 1.0.5 version bump (diff)
downloadgentoo-34588839f4fb5889eb9d1f2de53efd361506e8c4.tar.gz
gentoo-34588839f4fb5889eb9d1f2de53efd361506e8c4.tar.bz2
gentoo-34588839f4fb5889eb9d1f2de53efd361506e8c4.zip
media-libs/libiptcdata: Minor ebuild style++
Sort dependencies. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/libiptcdata/libiptcdata-1.0.5.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/media-libs/libiptcdata/libiptcdata-1.0.5.ebuild b/media-libs/libiptcdata/libiptcdata-1.0.5.ebuild
index e83c9fc1c5b4..0aaea7ec8323 100644
--- a/media-libs/libiptcdata/libiptcdata-1.0.5.ebuild
+++ b/media-libs/libiptcdata/libiptcdata-1.0.5.ebuild
@@ -16,11 +16,15 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc examples nls python"
-RDEPEND="python? ( ${PYTHON_DEPS} )
- nls? ( virtual/libintl )"
+RDEPEND="
+ nls? ( virtual/libintl )
+ python? ( ${PYTHON_DEPS} )
+"
DEPEND="${RDEPEND}"
-BDEPEND="nls? ( >=sys-devel/gettext-0.13.1 )
- doc? ( >=dev-util/gtk-doc-1 )"
+BDEPEND="
+ doc? ( >=dev-util/gtk-doc-1 )
+ nls? ( >=sys-devel/gettext-0.13.1 )
+"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -29,9 +33,11 @@ pkg_setup() {
}
src_configure () {
- local myeconfargs=( $(use_enable nls)
+ local myeconfargs=(
+ $(use_enable nls)
$(use_enable python)
- $(use_enable doc gtk-doc) )
+ $(use_enable doc gtk-doc)
+ )
econf "${myeconfargs[@]}"
}