summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-03-31 16:47:47 +0100
committerSam James <sam@gentoo.org>2024-04-01 08:13:55 +0100
commit34734a17a456ded2122211876e2ff3612ee259d1 (patch)
tree24acd5624e187c77385825d97cf55bff323df9ef
parentapp-admin/consul-template: add 0.37.4 (diff)
downloadgentoo-34734a17a456ded2122211876e2ff3612ee259d1.tar.gz
gentoo-34734a17a456ded2122211876e2ff3612ee259d1.tar.bz2
gentoo-34734a17a456ded2122211876e2ff3612ee259d1.zip
dev-util/bear: limit parallelism
I can't find a way to pass -l through cmake --build of ExternalProject, but at least it passes -j now [sam: added Bug: tag.] Bug: https://bugs.gentoo.org/928346 Closes: https://bugs.gentoo.org/922199 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/36016 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/bear/bear-3.1.3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-util/bear/bear-3.1.3.ebuild b/dev-util/bear/bear-3.1.3.ebuild
index c9917bdeddae..f00fc1e688f8 100644
--- a/dev-util/bear/bear-3.1.3.ebuild
+++ b/dev-util/bear/bear-3.1.3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake python-any-r1
+inherit cmake multiprocessing python-any-r1
DESCRIPTION="Build EAR generates a compilation database for clang tooling"
HOMEPAGE="https://github.com/rizsotto/Bear"
@@ -55,6 +55,9 @@ src_prepare() {
}
src_configure() {
+ # TODO: remove this when https://bugs.gentoo.org/928346 is fixed
+ export CMAKE_BUILD_PARALLEL_LEVEL=$(makeopts_jobs)
+
local mycmakeargs=(
-DENABLE_UNIT_TESTS="$(usex test)"
-DENABLE_FUNC_TESTS="$(usex test)"