summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-07 14:55:42 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-12 20:08:16 +0100
commit3484d2aa661c41594c54bb32b2f3b97cf0a2e172 (patch)
tree7c99a9a6a5e4aaed27b2229f06aae3b876d860fe
parentnet-analyzer/icinga2: [QA] Remove invalid USE=lto (diff)
downloadgentoo-3484d2aa661c41594c54bb32b2f3b97cf0a2e172.tar.gz
gentoo-3484d2aa661c41594c54bb32b2f3b97cf0a2e172.tar.bz2
gentoo-3484d2aa661c41594c54bb32b2f3b97cf0a2e172.zip
net-analyzer/netdata: [QA] Remove invalid USE=lto
USE=lto is only used to append -flto. Remove it. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-analyzer/netdata/netdata-1.44.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-analyzer/netdata/netdata-1.44.0.ebuild b/net-analyzer/netdata/netdata-1.44.0.ebuild
index f0470bbdd4ca..a85bf1232c4b 100644
--- a/net-analyzer/netdata/netdata-1.44.0.ebuild
+++ b/net-analyzer/netdata/netdata-1.44.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python{3_9,3_10,3_11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools fcaps flag-o-matic linux-info optfeature python-single-r1 systemd toolchain-funcs
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps cloud +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc +lto mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+IUSE="caps cloud +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -105,6 +105,7 @@ src_configure() {
[[ $(tc-endian) == big ]] && append-flags -mno-vsx
fi
+ # --enable-lto only appends -flto
econf \
--localstatedir="${EPREFIX}"/var \
--with-user=netdata \
@@ -116,7 +117,7 @@ src_configure() {
$(use_enable nfacct plugin-nfacct) \
$(use_enable ipmi plugin-freeipmi) \
--disable-exporting-kinesis \
- $(use_enable lto lto) \
+ --disable-lto \
$(use_enable mongodb exporting-mongodb) \
$(use_enable prometheus exporting-prometheus-remote-write) \
$(use_enable xen plugin-xenstat) \