summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-10-11 10:32:15 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-12-27 20:51:23 +0100
commit348f983d594532fe92d6f73f603898aa7d0cbc35 (patch)
tree477977d05a286c081a6b7f3ca96d3afe0394f373
parentdev-java/xmpbox: add 2.0.27 (diff)
downloadgentoo-348f983d594532fe92d6f73f603898aa7d0cbc35.tar.gz
gentoo-348f983d594532fe92d6f73f603898aa7d0cbc35.tar.bz2
gentoo-348f983d594532fe92d6f73f603898aa7d0cbc35.zip
dev-java/commons-daemon: add 1.3.3
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/27735 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/commons-daemon/Manifest2
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.3.3.ebuild56
-rw-r--r--dev-java/commons-daemon/metadata.xml4
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-java/commons-daemon/Manifest b/dev-java/commons-daemon/Manifest
index 97c35db071c4..036b63e7f03e 100644
--- a/dev-java/commons-daemon/Manifest
+++ b/dev-java/commons-daemon/Manifest
@@ -1 +1,3 @@
DIST commons-daemon-1.3.1-src.tar.gz 287642 BLAKE2B 02e85a5534af7f804a0374789506ee25ee8313987c68153974aa938b983745ae44d579f17deb362764d1a03b04bc552115bd69ef28b4f7d3bbb06f3bb4199814 SHA512 b810ac152f8296d980a4fb3786eff9d147b234dc2377df5fe1bded0824c694c9e82a7ef50b0a63c3e6432dfc4684a3aa2ce8d583aacb740bd4664c3dfb8b8f16
+DIST commons-daemon-1.3.3-src.tar.gz 290415 BLAKE2B c9c175ba52cef25ce6d1b56c7466aa5e775ed1ac3ca7c710c3519574c35e8a66ff5846313de8da594511ad411e802b7e0b647cbfd66a50abaaa0d39574a4e103 SHA512 ec246e2c05d66408374ba56b3715b13f8f24f89af11fa00c2381dc19c188f1b6228f19351c97d5774808a804b83fdbdfb8f537d099db062c39ffd281c142ee77
+DIST commons-daemon-1.3.3-src.tar.gz.asc 873 BLAKE2B 01fc7ec60393f2077a2bbf80aacb1a03b821cb52f88d87010f26a5811e2695d08b7c01193d00c2fb1a28bb875b63a5a0a935feadf7c1f00c4799aafa32592804 SHA512 c42b36acd45665daeda06a59006f05fd9846817e4e1065ef89dfedef060216ecce0316d06400437e4fb5138cf41c2fe52790cd5da9306c64e3000a3765bad2a2
diff --git a/dev-java/commons-daemon/commons-daemon-1.3.3.ebuild b/dev-java/commons-daemon/commons-daemon-1.3.3.ebuild
new file mode 100644
index 000000000000..e9295396443f
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.3.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/commons/daemon/source/commons-daemon-1.3.3-src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild commons-daemon-1.3.3.ebuild
+
+EAPI=8
+
+# No tests because "package org.junit.jupiter.api does not exist"
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="commons-daemon:commons-daemon:1.3.3"
+
+inherit java-pkg-2 java-pkg-simple toolchain-funcs verify-sig
+
+DESCRIPTION="Tools to allow Java programs to run as UNIX daemons"
+HOMEPAGE="https://commons.apache.org/proper/commons-daemon/"
+SRC_URI="mirror://apache/commons/daemon/source/${P}-src.tar.gz
+ verify-sig? ( https://downloads.apache.org/commons/daemon/source/commons-daemon-${PV}-src.tar.gz.asc )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-apache-commons )"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/commons.apache.org.asc"
+
+DOCS=( {CONTRIBUTING,README}.md {HOWTO-RELEASE,NOTICE,RELEASE-NOTES}.txt )
+HTML_DOCS=( PROPOSAL.html )
+PATCHES=( "${FILESDIR}/commons-daemon-1.3.1-Make.patch" )
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="iso-8859-1"
+JAVA_SRC_DIR="src/main/java"
+
+src_prepare() {
+ default #780585
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+
+ pushd src/native/unix || die
+ ./configure
+ emake AR="$(tc-getAR)"
+ popd
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dobin src/native/unix/jsvc
+}
diff --git a/dev-java/commons-daemon/metadata.xml b/dev-java/commons-daemon/metadata.xml
index 4818627a6525..cfdf736c966a 100644
--- a/dev-java/commons-daemon/metadata.xml
+++ b/dev-java/commons-daemon/metadata.xml
@@ -8,4 +8,8 @@
<longdescription>
Apache Commons Daemon software is a set of utilities and Java support classes for running Java applications as server processes. These are commonly known as 'daemon' processes in Unix terminology (hence the name). On Windows they are called 'services'
</longdescription>
+ <upstream>
+ <doc>https://cwiki.apache.org/confluence/display/commons/Daemon</doc>
+ <bugs-to>https://issues.apache.org/jira/browse/DAEMON</bugs-to>
+ </upstream>
</pkgmetadata>