summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-08-27 20:43:13 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-08-27 22:05:32 +0100
commit3496e0734aea0e27e88cfe7b5bf804714c5fcba6 (patch)
tree5033cb161d7eec0f1f3d52ea360bbaa09791a456
parentsys-kernel/gentoo-sources: stable 4.9.122 for ia64, bug #663744 (diff)
downloadgentoo-3496e073.tar.gz
gentoo-3496e073.tar.bz2
gentoo-3496e073.zip
net-print/c2esp: Version bump to 27, EAPI 7
This now uses CMake, which is much less painful. Unfortunately my old printer turned out to be dead so this has only been build tested. Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--net-print/c2esp/Manifest1
-rw-r--r--net-print/c2esp/c2esp-27.ebuild29
-rw-r--r--net-print/c2esp/files/0001-Fix-various-missing-includes.patch35
3 files changed, 65 insertions, 0 deletions
diff --git a/net-print/c2esp/Manifest b/net-print/c2esp/Manifest
index bbe6a99c9954..c3a56a3241be 100644
--- a/net-print/c2esp/Manifest
+++ b/net-print/c2esp/Manifest
@@ -1,2 +1,3 @@
+DIST c2esp-27.tar.gz 143551 BLAKE2B 7cc80fd72eed24c24cb153d7395a692849c51249ca40a563f94bedbb82c6d976bce6b44d47dbe21c36ec40f26571178f562b175485f404d356724b4bc3f611bf SHA512 d3ff9dc6de7cf692e4be4f4b316f862d271bff06181f0000daf1ce2fb6921f1b24efe88ec24f7b811d78cb9dca18fcba3f17dd5273ac84ceb9f6bfcecedeecce
DIST c2esp25c.tar.gz 338047 BLAKE2B 645127bdd61f478d519a7d17a1f621357e0c80ac6b313832ddcaba6744cb7f4a62a592c1140293e78a3a63447ad7295bd3fcda0f6f18f0d33b1cca0cca162803 SHA512 788da75c0049c1aa445890d67a7088bc4e7aa5c4e3e67689677fa5bee0e17e29fbb6e7ba9397aaec99f43ba79043aca7d147b6c510e3dd472d238ce6e2636b12
DIST c2esp26.tar.gz 127593 BLAKE2B 84e6ff61fc5af225526a569861bf316a2b7b1aa8f2bf4d7af15a04042f9dd2da7726d34b66d12dea8748532a54d5ae3a1b0bbfafdccccbea192725751cf3416e SHA512 aa1ca61f895de4892e1058b349fcf1830da78455ffbd0d9989b7ac4e922076e184de91a2b79f285d946d29ece7a6d8159f62c900ed8d6c76859a4261c92da359
diff --git a/net-print/c2esp/c2esp-27.ebuild b/net-print/c2esp/c2esp-27.ebuild
new file mode 100644
index 000000000000..69e58fbb92f9
--- /dev/null
+++ b/net-print/c2esp/c2esp-27.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A CUPS filter for Kodak ESP printers"
+HOMEPAGE="https://sourceforge.net/projects/cupsdriverkodak"
+SRC_URI="mirror://sourceforge/cupsdriverkodak/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND=">=media-libs/jbigkit-2.0-r1:=
+ >=net-print/cups-1.6
+ sys-libs/zlib:="
+
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/0001-Fix-various-missing-includes.patch
+)
+
+src_configure() {
+ # Don't trust cups-config in case ROOT!=/.
+
+ econf \
+ --with-cupsfilterdir="${EPREFIX}"/usr/libexec/cups/filter \
+ --with-cupsdatadir="${EPREFIX}"/usr/share/cups
+}
diff --git a/net-print/c2esp/files/0001-Fix-various-missing-includes.patch b/net-print/c2esp/files/0001-Fix-various-missing-includes.patch
new file mode 100644
index 000000000000..bde86e666688
--- /dev/null
+++ b/net-print/c2esp/files/0001-Fix-various-missing-includes.patch
@@ -0,0 +1,35 @@
+From 4341f243a34dbb8140800337d189345c370dc499 Mon Sep 17 00:00:00 2001
+From: Didier Raboud <odyx@debian.org>
+Date: Fri, 9 Feb 2018 17:23:25 +0100
+Subject: Fix various missing includes
+
+Last-Update: 2016-10-03
+---
+ src/c2espcommon.h | 1 +
+ src/command2esp.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/c2espcommon.h b/src/c2espcommon.h
+index 471f46a..088a2b8 100644
+--- a/src/c2espcommon.h
++++ b/src/c2espcommon.h
+@@ -19,6 +19,7 @@
+ */
+
+ #include <cups/sidechannel.h> //FlushBackChannel, and the side channel functions and constants
++#include <stdio.h> // FILE
+ #include <fcntl.h> //files
+ #include <time.h> //time functions used for debugging
+
+diff --git a/src/command2esp.c b/src/command2esp.c
+index 529342c..e30357e 100644
+--- a/src/command2esp.c
++++ b/src/command2esp.c
+@@ -44,6 +44,7 @@ Maintenance=003?
+ #include <cups/cups.h>
+ #include <cups/sidechannel.h> //FlushBackChannel, and the side channel functions and constants
+ #include "string.h"
++#include "strings.h" // strncasecmp
+ #include <ctype.h>
+ #include <fcntl.h> //files
+ #include <time.h> //time functions used for debugging