summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-30 23:05:41 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-30 23:05:47 +0100
commit349e168da5d78c75bd210ff893a7b580dfe5b4fe (patch)
tree97d1b0059828f258099480e7d47552de76944efb
parentgnome-extra/gnome-calculator: Version bump to 40.1 (diff)
downloadgentoo-349e168da5d78c75bd210ff893a7b580dfe5b4fe.tar.gz
gentoo-349e168da5d78c75bd210ff893a7b580dfe5b4fe.tar.bz2
gentoo-349e168da5d78c75bd210ff893a7b580dfe5b4fe.zip
sys-firmware/seabios: tweak linker script for binutils-2.36
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-firmware/seabios/files/seabios-1.14.0-binutils-2.36.patch9
-rw-r--r--sys-firmware/seabios/seabios-1.14.0-r1.ebuild4
2 files changed, 13 insertions, 0 deletions
diff --git a/sys-firmware/seabios/files/seabios-1.14.0-binutils-2.36.patch b/sys-firmware/seabios/files/seabios-1.14.0-binutils-2.36.patch
new file mode 100644
index 000000000000..0453d203d4ae
--- /dev/null
+++ b/sys-firmware/seabios/files/seabios-1.14.0-binutils-2.36.patch
@@ -0,0 +1,9 @@
+--- a/vgasrc/vgalayout.lds.S
++++ b/vgasrc/vgalayout.lds.S
+@@ -19,5 +19,5 @@ SECTIONS
+
+ // Discard regular data sections to force a link error if
+ // 16bit code attempts to access data not marked with VAR16.
+- /DISCARD/ : { *(.text*) *(.rodata*) *(.data*) *(.bss*) *(COMMON) }
++ /DISCARD/ : { *(.text*) *(.rodata*) *(.data*) *(.bss*) *(COMMON) *(.note.gnu.property) }
+ }
diff --git a/sys-firmware/seabios/seabios-1.14.0-r1.ebuild b/sys-firmware/seabios/seabios-1.14.0-r1.ebuild
index a8b5184144ac..f97b51857b56 100644
--- a/sys-firmware/seabios/seabios-1.14.0-r1.ebuild
+++ b/sys-firmware/seabios/seabios-1.14.0-r1.ebuild
@@ -95,6 +95,10 @@ src_unpack() {
src_prepare() {
default
+ if ! use binary; then
+ eapply "${FILESDIR}"/${PN}-1.14.0-binutils-2.36.patch
+ fi
+
# Ensure precompiled iasl files are never used
find "${WORKDIR}" -name '*.hex' -delete || die
}