summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2023-04-13 18:03:59 +0800
committerSam James <sam@gentoo.org>2023-04-14 02:05:22 +0100
commit34aaa2a10885275756493b0e234bc1c1060c8ba8 (patch)
tree31c6f2574e6ba4910dda567424adc5530c678af9
parentmedia-gfx/flameshot: fix wayland clipboard behavior (diff)
downloadgentoo-34aaa2a10885275756493b0e234bc1c1060c8ba8.tar.gz
gentoo-34aaa2a10885275756493b0e234bc1c1060c8ba8.tar.bz2
gentoo-34aaa2a10885275756493b0e234bc1c1060c8ba8.zip
media-gfx/flameshot: backport wayland fix to 12.0.0
Issue: https://bugs.gentoo.org/904266 Signed-off-by: Huang Rui <vowstar@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/flameshot/flameshot-12.0.0-r1.ebuild (renamed from media-gfx/flameshot/flameshot-12.0.0.ebuild)13
1 files changed, 8 insertions, 5 deletions
diff --git a/media-gfx/flameshot/flameshot-12.0.0.ebuild b/media-gfx/flameshot/flameshot-12.0.0-r1.ebuild
index cccbfdf33cd5..35e2aa26f399 100644
--- a/media-gfx/flameshot/flameshot-12.0.0.ebuild
+++ b/media-gfx/flameshot/flameshot-12.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,16 +12,18 @@ SRC_URI="https://github.com/flameshot-org/flameshot/archive/v${PV}.tar.gz -> ${P
LICENSE="Apache-2.0 Free-Art-1.3 GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="wayland"
DEPEND="
+ =dev-qt/qtsingleapplication-2.6*[qt5(+),X]
dev-qt/qtcore:5
+ dev-qt/qtdbus:5
dev-qt/qtgui:5
- =dev-qt/qtsingleapplication-2.6*[qt5(+),X]
- dev-qt/qtwidgets:5
- dev-qt/qtsvg:5
dev-qt/qtnetwork:5
- dev-qt/qtdbus:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
sys-apps/dbus
+ wayland? ( kde-frameworks/kguiaddons )
"
BDEPEND="
dev-qt/linguist-tools:5
@@ -38,6 +40,7 @@ src_configure() {
local mycmakeargs=(
-DUSE_EXTERNAL_SINGLEAPPLICATION=1
-DENABLE_CACHE=0
+ -DUSE_WAYLAND_CLIPBOARD=$(usex wayland)
)
cmake_src_configure