summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-04 07:51:56 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-04 08:13:26 +0200
commit34bce2926847683f7d983db8e760c685f8ce23cf (patch)
treec35105dcc2a5cf714152b962369ce7a201175c30
parentdev-python/botocore: Bump to 1.21.13 (diff)
downloadgentoo-34bce2926847683f7d983db8e760c685f8ce23cf.tar.gz
gentoo-34bce2926847683f7d983db8e760c685f8ce23cf.tar.bz2
gentoo-34bce2926847683f7d983db8e760c685f8ce23cf.zip
dev-python/boto3: Bump to 1.18.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.13.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f8da7f4e6a76..85fb16bd9be8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,6 +5,7 @@ DIST boto3-1.18.1.tar.gz 392759 BLAKE2B bfa0bcfba9a413fbb13b2698f3ef2461cac99a9f
DIST boto3-1.18.10.tar.gz 398199 BLAKE2B 950b40afd867a8df9f8154e35572f3302c03c686d3299aac100ffd18a82c9e9a6657a4910f89f385dfb742c32e315110fc61bf00d2dc14892c4051eef5c642c8 SHA512 0391faf993faf8f4cc28e309f3267acc1beb38229f633f4c409820d45e968b1a93a7c74798ee84aebcd29b4547c9f301decd451e89b65a34297f796e1f839826
DIST boto3-1.18.11.tar.gz 398542 BLAKE2B cecccf462510a6deb55308ea4156ae081d2357480e5d8c160797032c62554ac708f37b38e1cbe26a18e2087a268b392a145d0733400a86e4fca19a5416700ad8 SHA512 63cbea62fcd71fee1c53219f6016fe38bd08afdef0c27d918bd078d04803d14ddd4782c0182e304542314df4bcf081d802d1f581b25ccae3327c4df80e40dabe
DIST boto3-1.18.12.tar.gz 398935 BLAKE2B 87f8627459908e4ff4bfde7ca7d325a355635c8e7c77cee515d30a443bfaba8474e3637e8facd8fd77778c2faab272e6526df92e96c59db4901bd3be44fce24d SHA512 bef678df9f073bb56152e8e56b4341e40aa98120ded26d1794d3e91382a994929150a06eee543d5397f065e66a9dad192b1a30e89f9d430f8a305a6d1e5a99b9
+DIST boto3-1.18.13.tar.gz 399893 BLAKE2B 3c3e79e2a8ea41a6bf88a2e73926d6e61c9844fe0d373126611e3023d98d9e6a64cf7b537726260ae70fd78fea32f19127d59ddac5d48489be231bfb2a51b693 SHA512 14987a472d5dd7eb254fa4fd4e931b43f36afc57b40676c0c2c2400bb24d7a31892d317b2da6d618311b5df91ee4a5c6cd4974ecf90971540c41b4d9632533ff
DIST boto3-1.18.2.tar.gz 393528 BLAKE2B 20424f9a8ff013d1d9724f741ad6754747de504fb961688f433eba74ce1d6df7e95d68c45be1e87df1532f99b2fa4d7e8b00671a8ae9a378a4df74764924cdaa SHA512 287a1f24f62fa83fd944632799540257b2f8d6cf3b5d6add57be60e4f49dafd685bb4fcceef37fe907edba00a7f2285d92bd8d381b03e45ac794b22fdcfe8783
DIST boto3-1.18.3.tar.gz 393645 BLAKE2B 4967ac751e9ff5a86f6f571961df31d82f6012ade28aa19a038399077bf5a1b968dfa1172995423890b79a2ede54e2c6f6c1937e8ccf21010f17a4d96928df62 SHA512 f9c42257f0925fffaeb1a36e4731dc54fee1836c249617444292991d043dbb9b58472f73a806981c9763b569cc7402b378f6e1e0102fe0f995a7754807f19b38
DIST boto3-1.18.4.tar.gz 394442 BLAKE2B e82726143b353b843e915ea78ea2e033077ee495b1d416866f5c231f8bd864372496736d266b2b848ed8afd3134bd865c507291fd2fbdd5cae00a92ce3c5e76d SHA512 b3ba1328476a1c642c6b813afc3879e904bc14da69e062156df0405b3da6d2a15a4a40602f24d0a067a83cc441ce5a5e353dacb84869b0fe24e9984c0dec719f
diff --git a/dev-python/boto3/boto3-1.18.13.ebuild b/dev-python/boto3/boto3-1.18.13.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.13.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}