summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-07-08 09:04:19 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-07-08 09:08:03 +0200
commit34e23e521abb9f3729a2a71455d5fb6a5e31965d (patch)
treea577015ab746084ca6c19ee1803f998fef518b22
parentdev-python/distlib: Remove old (diff)
downloadgentoo-34e23e52.tar.gz
gentoo-34e23e52.tar.bz2
gentoo-34e23e52.zip
x11-wm/icewm: Bump to version 2.6.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--x11-wm/icewm/Manifest1
-rw-r--r--x11-wm/icewm/icewm-2.6.0.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/x11-wm/icewm/Manifest b/x11-wm/icewm/Manifest
index 1054974c2311..f835819a892f 100644
--- a/x11-wm/icewm/Manifest
+++ b/x11-wm/icewm/Manifest
@@ -1,3 +1,4 @@
DIST icewm-2.3.4.tar.lz 1708239 BLAKE2B d19a7864642795b93a8d30a63c6ba0dcac4ee9b9e3a2b9e314e115aea8200f688ed46f70268f16d09c8c7a02c4ac9653c3937d1b029bdc5b69ddd5d3fba658c9 SHA512 97d613c3dda84bc52d6b31772df5422aef84b6055b7240e90e5e1a5433d0250ad8fde7a01c4d5c3e714265fed4a3feefde3d6e6b4e1433896c16d2b4708edb1a
DIST icewm-2.4.0.tar.lz 1718250 BLAKE2B 6ed4893d11ba7957c34585ec345d2ceaf23ceecf1d87e59c73cae0d730104a1f4850744d097cd4f00eb29cbfa413b9933d840cee55c36831f7acad571929b76f SHA512 2ac7509ce64a7d7772e12220f935f2511f8a9160bc9672421d81c49dcabc90d22559558811a11697f4e7c45a23a788b4d73032d2e1201c1dc502897ba6e9c965
DIST icewm-2.5.0.tar.lz 1722504 BLAKE2B caf5d61559dd5bb25583bebeaca82e54049e2a97d8e5eeb93942908481f68614cfe55afd4041b5d60e58e732fef1694f67c5918a130bc55b252ebae67a51482a SHA512 1f59b4dbe90ca47031e5abf999cdb23a8e9ea956d5a76a0dde9b3489dec4530bf0ce72e10b337615d0bcadf04007b00a7db6f43082504bef65b109f9115d9f52
+DIST icewm-2.6.0.tar.lz 1722772 BLAKE2B 4d7055b77d88d0731517b668f525161a97b571f68cf0b2944e9b364653cb022f0b29d664ccc9539d1807005ab8954aa3ce31244911c2fafaa673ef5afeb447f1 SHA512 fe491c8c59aa530d48a20134857c787eccfeda5bd9529e063d865bd3c5f243ef41fbecba40aa06e7fa8037af89839958095debebc5d9b1acc9b5670bd0e12eb6
diff --git a/x11-wm/icewm/icewm-2.6.0.ebuild b/x11-wm/icewm/icewm-2.6.0.ebuild
new file mode 100644
index 000000000000..7b0d626e90a0
--- /dev/null
+++ b/x11-wm/icewm/icewm-2.6.0.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools unpacker
+
+DESCRIPTION="Ice Window Manager with Themes"
+HOMEPAGE="https://ice-wm.org/ https://github.com/ice-wm/icewm"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/ice-wm/icewm/releases/download/${PV}/${P}.tar.lz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+alsa ao bidi debug +gdk-pixbuf imlib nls truetype uclibc xinerama"
+
+# Tests broken in all versions, patches welcome, bug #323907, #389533
+RESTRICT="test"
+
+REQUIRED_USE="|| ( alsa ao )"
+#?? ( gdk-pixbuf imlib )
+
+#fix for icewm preversion package names
+S="${WORKDIR}/${P/_}"
+
+# These are the core dependencies of icewm.
+# Look into configure.ac and search for PKG_CHECK_MODULES([CORE]
+CORE_DEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+"
+
+RDEPEND="
+ ${CORE_DEPEND}
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/libsndfile[alsa]
+ )
+ ao? (
+ media-libs/libao
+ media-libs/libsndfile
+ )
+ bidi? ( dev-libs/fribidi )
+ gdk-pixbuf? (
+ x11-libs/gdk-pixbuf-xlib
+ >=x11-libs/gdk-pixbuf-2.42.0:2
+ )
+ !gdk-pixbuf? (
+ imlib? (
+ gnome-base/librsvg:2
+ media-libs/imlib2
+ )
+ !imlib? (
+ media-libs/libpng:0=
+ virtual/jpeg
+ )
+ )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ $(unpacker_src_uri_depends)
+ x11-base/xorg-proto
+ gdk-pixbuf? ( gnome-base/librsvg:2 )
+"
+
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.19.8 )
+"
+
+pkg_pretend() {
+ if use gdk-pixbuf && use imlib ; then
+ einfo 'Confilcting USE flags have been enabled:'
+ einfo '"gdk-pixbuf" and "imlib" exclude each other!'
+ einfo 'Using "gdk-pixbuf".'
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local icesound
+ if use alsa && use ao ; then
+ icesound="alsa,ao"
+ elif use alsa ; then
+ icesound="alsa"
+ elif use ao ; then
+ icesound="ao"
+ fi
+
+ local myconf=(
+ --enable-logevents
+ --enable-xrandr
+ --with-cfgdir="${EPREFIX}"/etc/icewm
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --with-icesound="${icesound}"
+ --with-libdir="${EPREFIX}"/usr/share/icewm
+ $(use_enable bidi fribidi)
+ $(use_enable debug)
+ $(use_enable debug logevents)
+ $(use_enable gdk-pixbuf)
+ $(use_enable imlib imlib2)
+ $(use_enable nls i18n)
+ $(use_enable nls)
+ $(use_enable xinerama)
+ )
+ if use truetype ; then
+ myconf+=(
+ --enable-shape
+ )
+ else
+ myconf+=(
+ --disable-xfreetype
+ --enable-corefonts
+ )
+ fi
+
+ econf "${myconf[@]}"
+
+ sed \
+ -e "s:/icewm-\$(VERSION)::" \
+ -e "s:ungif:gif:" \
+ -i src/Makefile || die
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README.md TODO VERSION )
+
+ default
+
+ docinto html
+ dodoc doc/icewm.html
+ dodoc man/*.html
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/icewm"
+}