summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2017-12-28 17:04:17 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2017-12-28 17:06:14 +0100
commit34f74cb47c8be9aab1548c5c1391f79f2761a20e (patch)
treef43fc095740b6348d2c2981102c8e03d66fae9c0
parentsci-electronics/pcb: Add ipcd56 to export formats (diff)
downloadgentoo-34f74cb4.tar.gz
gentoo-34f74cb4.tar.bz2
gentoo-34f74cb4.zip
sci-electronics/pcb: Fix testsuite.
Do not count skipped tests as failed. Closes: https://bugs.gentoo.org/642366 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sci-electronics/pcb/files/pcb-4.0.2-tests.diff14
-rw-r--r--sci-electronics/pcb/pcb-4.0.2.ebuild2
2 files changed, 16 insertions, 0 deletions
diff --git a/sci-electronics/pcb/files/pcb-4.0.2-tests.diff b/sci-electronics/pcb/files/pcb-4.0.2-tests.diff
new file mode 100644
index 000000000000..9c6052ee7d73
--- /dev/null
+++ b/sci-electronics/pcb/files/pcb-4.0.2-tests.diff
@@ -0,0 +1,14 @@
+# Do not count skipped tests as failed (bug #642366)
+--- tests/run_tests.sh.orig 2017-12-28 16:40:57.657366187 +0100
++++ tests/run_tests.sh 2017-12-28 16:42:57.183392063 +0100
+@@ -842,8 +842,9 @@
+ show_sep
+ echo "Passed $pass, failed $fail, skipped $skip out of $tot tests."
+
++sum=`expr $skip + $pass`
+ rc=0
+-if test $pass -ne $tot ; then
++if test $sum -ne $tot ; then
+ rc=1
+ fi
+
diff --git a/sci-electronics/pcb/pcb-4.0.2.ebuild b/sci-electronics/pcb/pcb-4.0.2.ebuild
index a55cedbb76d0..9c72f3e67b0d 100644
--- a/sci-electronics/pcb/pcb-4.0.2.ebuild
+++ b/sci-electronics/pcb/pcb-4.0.2.ebuild
@@ -77,6 +77,8 @@ src_prepare() {
if ! use gcode; then
sed -i '/^hid_gcode/d' tests/tests.list || die
fi
+ # fix wrong accounting of skipped and passed tests
+ epatch "${FILESDIR}"/${P}-tests.diff
fi
# fix bad syntax in Makefile.am and configure.ac before running eautoreconf