summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2022-08-16 20:46:33 -0300
committerJoonas Niilola <juippis@gentoo.org>2022-08-31 11:31:19 +0300
commit34fdf9e74304b400b5ddb96fa076afb1359748b2 (patch)
treef7695cb23e18707e7c07c531936237a247a31b3e
parentmedia-libs/kcolorpicker: bump to 0.2.0 (diff)
downloadgentoo-34fdf9e7.tar.gz
gentoo-34fdf9e7.tar.bz2
gentoo-34fdf9e7.zip
media-libs/kimageannotator: bump to 0.6.0
Closes: https://bugs.gentoo.org/865453 Closes: https://github.com/gentoo/gentoo/pull/26887 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-libs/kimageannotator/Manifest1
-rw-r--r--media-libs/kimageannotator/kimageannotator-0.6.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/kimageannotator/Manifest b/media-libs/kimageannotator/Manifest
index 8239fd2d1eb5..531638629f6e 100644
--- a/media-libs/kimageannotator/Manifest
+++ b/media-libs/kimageannotator/Manifest
@@ -1,2 +1,3 @@
DIST kImageAnnotator-0.5.2.tar.gz 219008 BLAKE2B 6d2d53a55b013b8bb87291ffcb13126437291145a4d869c9e4b031711b8592ef465eb2b24b6473c09f9d02067d2404da15a4170a2f4e288cb1475d3c5d7d00be SHA512 42785f92954bf8fe28f5114d8ba7da9a1a22e79d1c0356642e34754218e580b147670a119d94e3b6b704deb1230a0d0f4d998541d5532783e4d569c66789af99
DIST kImageAnnotator-0.5.3.tar.gz 219782 BLAKE2B 30f532a563761a665da1f926629ebd66888f820b305c98f2b0afc316d8a94010196e68221a4ffd4871ffbae19582eee685af56c763f873b38a7ac5219f4a3b3d SHA512 a858e0f8694f3f989c36db586e6e3a302ad2aa9bf32b26afa170c165327fa33b6f3053682420c788f701abdea4daa35158058edddf52af1566364976b2d2f9f7
+DIST kImageAnnotator-0.6.0.tar.gz 257662 BLAKE2B 3736d0e862f1d3f3f9728e4d4d611c7e406d40fe022a2441b1a80355997d86a194064ecade63b7657d3cbf1f63364b8b74654d9c92d809ac056b7dc999d97415 SHA512 5782acd552af2297813164c0612810ec0d2127c174773040d99ec9d281f3575832b06667736a5521e88fa2d57ea6410e42a5d95232cb2dbdd9608917e5d6e896
diff --git a/media-libs/kimageannotator/kimageannotator-0.6.0.ebuild b/media-libs/kimageannotator/kimageannotator-0.6.0.ebuild
new file mode 100644
index 000000000000..430ca94fb112
--- /dev/null
+++ b/media-libs/kimageannotator/kimageannotator-0.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kImageAnnotator
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for annotating images"
+HOMEPAGE="https://github.com/ksnip/kImageAnnotator"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5[png]
+ >=media-libs/kcolorpicker-0.2.0
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qttest:5
+ dev-cpp/gtest
+ )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" virtx cmake_src_test
+}