summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-12-28 13:53:45 +0100
committerHans de Graaff <graaff@gentoo.org>2020-12-29 07:36:16 +0100
commit350384b4cbf898c49284506c1873e81504ae76bc (patch)
treec3eb357f32183a2041fb7bca4e750e77c4f524a0
parentdev-ml/camlp5: bump to 7.14 (diff)
downloadgentoo-350384b4.tar.gz
gentoo-350384b4.tar.bz2
gentoo-350384b4.zip
dev-ruby/rqrcode_core: add 0.2.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rqrcode_core/Manifest1
-rw-r--r--dev-ruby/rqrcode_core/rqrcode_core-0.2.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/rqrcode_core/Manifest b/dev-ruby/rqrcode_core/Manifest
index 2daf0bc1d185..43adb1e57d05 100644
--- a/dev-ruby/rqrcode_core/Manifest
+++ b/dev-ruby/rqrcode_core/Manifest
@@ -1,2 +1,3 @@
DIST rqrcode_core-0.1.0.tar.gz 20241 BLAKE2B 1d6f97cd8e1188c0a3ba0246d2102a901ac64fb0bb08317479f9061d3273ea49388e4a6ea02c8de6b54f8e928aefab62fe8b0dca8ba9f7ed31625cf84965df4b SHA512 30ba73f45d69360b0efbf543a774c709a4397bd8f726f4edeaa830397187cd5c7535ac5816d65cea00f356f7111f69629f03fa508b7a7fc91d5618c4cebd8167
DIST rqrcode_core-0.1.2.tar.gz 20165 BLAKE2B 7d8cabcb2258a667c3b27fcbd11988bbe5cba849b191c45f3288b4d096a6d13df614e64977ce633ec829f0350bbd7ee153342070845f5ed0d6121e6e2aab321a SHA512 9e4362b3b72193a20e44b636b3dfdbb7e496667b147e391660464ea6fd279720cbf4419e3d94561b61bee291c56fee8a3171f2287e2660f071dbda8d7153285b
+DIST rqrcode_core-0.2.0.tar.gz 20167 BLAKE2B 68ddad8e908404a9e156cffd0d1f2704671ffeaca0ce48a2a74b3512076d89812f19b537cbef98f3b0ae046486ab11f7681b187a07fb53539afb188bdcc87c21 SHA512 96a1fc3484aabfc30b9a26da705405e56cb82168d34ce252f35481b03142ddab359dfbfc4601d12f67f5a65d466120fc0a295c66c0a7ae07401b58cbd8d5c47a
diff --git a/dev-ruby/rqrcode_core/rqrcode_core-0.2.0.ebuild b/dev-ruby/rqrcode_core/rqrcode_core-0.2.0.ebuild
new file mode 100644
index 000000000000..71e3c38c4188
--- /dev/null
+++ b/dev-ruby/rqrcode_core/rqrcode_core-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rqrcode_core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="https://github.com/whomwah/rqrcode_core/"
+SRC_URI="https://github.com/whomwah/rqrcode_core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}