summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-09 17:55:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-09 18:02:21 +0100
commit350dcee9051f1027661821b99a4bd8768c12ea28 (patch)
treeb0740a7513678621f8a7d8c465d7d8d92abacc25
parentdev-python/xarray: Remove old (diff)
downloadgentoo-350dcee9051f1027661821b99a4bd8768c12ea28.tar.gz
gentoo-350dcee9051f1027661821b99a4bd8768c12ea28.tar.bz2
gentoo-350dcee9051f1027661821b99a4bd8768c12ea28.zip
dev-python/statsmodels: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/statsmodels/Manifest1
-rw-r--r--dev-python/statsmodels/statsmodels-0.13.2.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/statsmodels/Manifest b/dev-python/statsmodels/Manifest
index 3e322bed6787..679496d3c80e 100644
--- a/dev-python/statsmodels/Manifest
+++ b/dev-python/statsmodels/Manifest
@@ -1,3 +1,2 @@
-DIST statsmodels-0.13.2.tar.gz 17874260 BLAKE2B 93f7a308217ba938b3cd2e11d75e8f5ad19e2d4e6ab2abbea702143129bb53e7b9be54864375dbfec805624538bc73850357eb944d6c9a4c1252cc8a7606b904 SHA512 79d8dd63f667d4019e462d93e007a5ef8e11972fe35fb4d657931d6d68f3e35d29978a865682133db12fd6742f3362c2d77dfb5735c82ae454570388dd84d59a
DIST statsmodels-0.13.5.tar.gz 18364957 BLAKE2B 8357416b015b152612aca88a9ff42b81db4d97f61b1c255bc2baf8978440cd43fa1a5301d1c60e92b3a634008c5c001c00770685864d296587ff75e37d29ff4f SHA512 9aeeea80c69f52459140179523a0155429834b2951325c9781b28f8c4cbbd0593ff1867e2212078f2b898e4da953689c2fe78183d3c7959caa874e9d758b4ea4
DIST statsmodels-0.14.0.tar.gz 19374614 BLAKE2B b24c8c146ea9ed393da8e839e3c9a80b1ddaa6fe319204f4440b3435c756911bc1b6405544c6ab8e4370fd378ba26715da743e4d082af7774b8cefa8649d6c58 SHA512 876cc45eb4b5badee2ff859df8a45ce7c4f6ab2973d481f58c5b7906ebcdbb56a64769d5dd7a38c7b7415a4ee7cf98cf300b8c623bda9df001b982ff6844d1fd
diff --git a/dev-python/statsmodels/statsmodels-0.13.2.ebuild b/dev-python/statsmodels/statsmodels-0.13.2.ebuild
deleted file mode 100644
index 7338d961ffbb..000000000000
--- a/dev-python/statsmodels/statsmodels-0.13.2.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 multiprocessing optfeature pypi
-
-DESCRIPTION="Statistical computations and models for use with SciPy"
-HOMEPAGE="https://www.statsmodels.org/stable/index.html"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-DEPEND="
- >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.3[${PYTHON_USEDEP}]"
-RDEPEND="
- ${DEPEND}
- >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.25[${PYTHON_USEDEP}]
- >=dev-python/patsy-0.5.2[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.3[${PYTHON_USEDEP}]
-"
-# https://github.com/statsmodels/statsmodels/issues/8868 for <cython-3
-BDEPEND="
- ${DEPEND}
- <dev-python/cython-3[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- 'dev-python/ipykernel' \
- 'dev-python/jupyter-client' \
- 'dev-python/matplotlib' \
- 'dev-python/nbconvert' \
- 'dev-python/numpydoc'
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- export VARTEXFONTS="${T}"/fonts
- export MPLCONFIGDIR="${T}"
- printf -- 'backend : Agg\n' > "${MPLCONFIGDIR}"/matplotlibrc || die
-
- sed -e 's:test_combine:_&:' \
- -i statsmodels/imputation/tests/test_mice.py || die
- sed -e 's:test_mixedlm:_&:' \
- -i statsmodels/stats/tests/test_mediation.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x MKL_NUM_THREADS=1
- local -x OMP_NUM_THREADS=1
- local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
-
- pushd "${BUILD_DIR}" >/dev/null || die
- "${EPYTHON}" -c "
-import statsmodels
-statsmodels.test(extra_args=['-vv', '-n', '${jobs}'], exit=True)" \
- || die "tests fail with ${EPYTHON}"
- rm -rf statsmodels/.pytest_cache || die
- popd >/dev/null || die
-}
-
-python_install_all() {
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- fi
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "Plotting functionality" "dev-python/matplotlib"
-}