summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 01:55:36 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:17:44 +0100
commit351412908ebe686f91044c027dc8673ec138177c (patch)
treeb599be8495113849eec70e3a92cf60edf0ac003a
parentmedia-libs/libpano13: version bump (diff)
downloadgentoo-351412908ebe686f91044c027dc8673ec138177c.tar.gz
gentoo-351412908ebe686f91044c027dc8673ec138177c.tar.bz2
gentoo-351412908ebe686f91044c027dc8673ec138177c.zip
dev-games/newton: port to cmake.eclass (cmake-utils--)
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-games/newton/newton-3.14.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-games/newton/newton-3.14.ebuild b/dev-games/newton/newton-3.14.ebuild
index ef27f047fc4d..f1e04a4e16d0 100644
--- a/dev-games/newton/newton-3.14.ebuild
+++ b/dev-games/newton/newton-3.14.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils toolchain-funcs
+inherit cmake
MY_P="${PN}-dynamics-${P}"
DESCRIPTION="Integrated solution for real time simulation of physics environments"
HOMEPAGE="http://newtondynamics.com/forum/newton.php"
SRC_URI="https://github.com/MADEAPPS/newton-dynamics/archive/${P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND=""
DEPEND="dev-libs/tinyxml"
-S=${WORKDIR}/${MY_P}
-
src_prepare() {
- cmake-utils_src_prepare
sed -i -e '/packages/d' CMakeLists.txt || die
+ cmake_src_prepare
}
src_configure() {
@@ -30,5 +27,5 @@ src_configure() {
-DNEWTON_DEMOS_SANDBOX=OFF
-DCMAKE_VERBOSE_MAKEFILE=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}