summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-13 11:40:39 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-13 11:40:39 +0200
commit35178bbae6a81d6a5cc4909385e8da0108d43733 (patch)
treed845fa58b4e3718ad1bd8cd102ced6b28ddf76a0
parentsys-devel/clang: Stop passing LLVM_CONFIG to 9.0+ (diff)
downloadgentoo-35178bba.tar.gz
gentoo-35178bba.tar.bz2
gentoo-35178bba.zip
dev-util/catfish: Bump to 1.4.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-1.4.10.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index eeb6e43f8a14..d6ac4ac11ed5 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1,3 +1,4 @@
+DIST catfish-1.4.10.tar.bz2 213951 BLAKE2B ff8f710d5f3b5d59e98bd6af9b1dd11499ea331b2d7c78945ebc1051d1b49d28069e47bd8aa3f12d57b646fc6764ccd4f365cda9fdfea15f5a3a4334b6e9b17e SHA512 baf9007b2ce2418fa5704e10884f509e4361505537e2ce70a7f8c8c61009094a09d7d032e0a6b4ca174f33bf76783ee2665f781cce47d2b236f2633e25192f29
DIST catfish-1.4.7.tar.bz2 162289 BLAKE2B 2f24485f0f059a177a8544632ab583acad1149f96921f8b10027e5788adb2eaf4da0911f3363174feef570c8f75615ec1f943a2d5d2e8622efd4be9892a0fcd2 SHA512 cafa8eaaa40522f50111b3bb9c09a116ebad827532b0cfc88bc643fb2e2d89edee53057fbbed23719f4091ca384d7ea025633e571e160d7dfced008f788a3ffd
DIST catfish-1.4.8.tar.bz2 181027 BLAKE2B c03270832cb2e6bdc39528801d257d37c52f0c6f361c9225002c31a258a18a1c98cf7af640ca15a4f6e32ac4ac802bda84327123a7bf13d47a1410e67988bfab SHA512 46c9e9112116e0f8ee7957c5a71d16ecdde8c16a60a030f3339933a6f9e73d61d360fed52d5904b0fff21448050cc17df5af63f6254476404760fe9166dfad00
DIST catfish-1.4.9.tar.bz2 182247 BLAKE2B 343a9a83bed73a5f0416fa2ec61869dd3fdb13b8bc45a46dba7d4901c36d97b17e9f32f616baae8cceece566f4e529d34e55f81cb071504b750f4edda048185b SHA512 c62596a09ed481eac5a4544dcfcc71c02177c115b6bf050b1f2421a575ef589c0c1569ef26d6864e472f2331f0561c7f1146c58bc7873af8036d6e7350465c3d
diff --git a/dev-util/catfish/catfish-1.4.10.ebuild b/dev-util/catfish/catfish-1.4.10.ebuild
new file mode 100644
index 000000000000..8833b3e29740
--- /dev/null
+++ b/dev-util/catfish/catfish-1.4.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ virtual/freedesktop-icon-theme
+"
+DEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ rm -r "${ED%/}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}