summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-09 06:39:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-09 06:39:01 +0100
commit3518445e8d73ff0886ac50401f4935ad2bdb434e (patch)
tree8487722ad0f904c50e12ae0d323bf46d8f9918a4
parentdev-python/Faker: Bump to 22.1.0 (diff)
downloadgentoo-3518445e8d73ff0886ac50401f4935ad2bdb434e.tar.gz
gentoo-3518445e8d73ff0886ac50401f4935ad2bdb434e.tar.bz2
gentoo-3518445e8d73ff0886ac50401f4935ad2bdb434e.zip
dev-python/jupyter-core: Bump to 5.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter-core/Manifest1
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.7.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/Manifest b/dev-python/jupyter-core/Manifest
index 94d4a3d6d0da..e193631b6aac 100644
--- a/dev-python/jupyter-core/Manifest
+++ b/dev-python/jupyter-core/Manifest
@@ -3,3 +3,4 @@ DIST jupyter_core-5.5.1.tar.gz 85962 BLAKE2B a00e96b417d86cc66ac483d031919483ded
DIST jupyter_core-5.6.0.tar.gz 86418 BLAKE2B 70ab01fc13772f772c374a9452f36926f43bf85c6a19108592ce91238df137116f683692a69cbbb2693a87222728b76de0d4b80563bcd5b6d9019aac874e1d91 SHA512 2a2ff1a6ecc12adbd98b1beaea6206f58fe6d24b841102a436ed42106639992454eb4af2515ff268e95749fa01c3352ac1c919bfb053f3ebe22e1d9d9f9e03d3
DIST jupyter_core-5.6.1.tar.gz 86268 BLAKE2B ad9c04813367ae649002dfea236276e98665dab0dc6484939024eba94e4e687defffebb39f95d2ee8f9a2784388a88996f7dee8cbe93331984ac0e5528243d86 SHA512 ba774e0265a0917d64abb2261dac6ea1e9c6cb2d48f0b988367e3f62b5365481f43141a2904535ba5521246f7409f8eee356418e7cb10deb74859125dfcba0f9
DIST jupyter_core-5.7.0.tar.gz 87053 BLAKE2B f84eb30745ddf552e0575ee46519c2734d148f61d026c2e0529827342ca29cdeebe7e5866bf9a0c77b3309236f60c2e2303bd6fbc45ebdd6eef696a81d239f84 SHA512 550587edbb31a4c90f60efffa9236b27a3d4b315056f64f4fe79b4396a9c40c769d6263b3bb01d58d92148db8fc24347f3136c59c4b7ffad8c9fa305623cb387
+DIST jupyter_core-5.7.1.tar.gz 87137 BLAKE2B c1ec5a5fd079b50c12559bb1f5dfd54b43e530142d0062b48b3bbbccf8e560907f8c150206ce5f3b510b89d64ae87e4e81b908aaa7a6a17c3a6775b59fef42fd SHA512 e7042eadc2b3b8254a9a728bb3549c744a74c10cbdcc1dda493a6d2c0a2d9c8496edc2c787c78104f93a871879015d411d5260eda470f7a7d087b5cf5dce44cb
diff --git a/dev-python/jupyter-core/jupyter-core-5.7.1.ebuild b/dev-python/jupyter-core/jupyter-core-5.7.1.ebuild
new file mode 100644
index 000000000000..0f5aa60a25ca
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.11.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest