summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-03 16:39:21 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-03 16:44:08 +0100
commit351c5f4493f4f0b8714dd9da949178e7f70e7847 (patch)
treee4cb975e781db9b712c14d12b21bdc7f1b6c1de1
parentsys-devel/lld: Remove 13.0.1.9999 (diff)
downloadgentoo-351c5f4493f4f0b8714dd9da949178e7f70e7847.tar.gz
gentoo-351c5f4493f4f0b8714dd9da949178e7f70e7847.tar.bz2
gentoo-351c5f4493f4f0b8714dd9da949178e7f70e7847.zip
dev-python/lit: Remove 13.0.1.9999
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lit/lit-13.0.1.9999.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/lit/lit-13.0.1.9999.ebuild b/dev-python/lit/lit-13.0.1.9999.ebuild
deleted file mode 100644
index 89c5315a5acb..000000000000
--- a/dev-python/lit/lit-13.0.1.9999.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 llvm.org
-
-DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
-HOMEPAGE="https://llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Tests require 'FileCheck' and 'not' utilities (from llvm)
-BDEPEND="
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
- )"
-
-LLVM_COMPONENTS=( llvm/utils/lit )
-llvm.org_set_globals
-
-# TODO: move the manpage generation here (from sys-devel/llvm)
-
-src_prepare() {
- cd "${WORKDIR}" || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x LIT_PRESERVES_TMP=1
- local litflags=$(get_lit_flags)
- ./lit.py ${litflags//;/ } tests || die
-}