summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2017-11-14 16:54:03 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-16 13:59:27 +0100
commit353d61e3e9ffc32a4d60c18b7146a706d1e1757d (patch)
treed3c6594a39bc093ed16a284a0089c9434884a8ac
parentnet-misc/networkmanager-openconnect: amd64/x86 stable, bug #638808 (diff)
downloadgentoo-353d61e3e9ffc32a4d60c18b7146a706d1e1757d.tar.gz
gentoo-353d61e3e9ffc32a4d60c18b7146a706d1e1757d.tar.bz2
gentoo-353d61e3e9ffc32a4d60c18b7146a706d1e1757d.zip
dev-python/pyilmbase: new package.
Closes: https://bugs.gentoo.org/634968 Closes: https://github.com/gentoo/gentoo/pull/6083 Package-Manager: Portage-2.3.14, Repoman-2.3.5
-rw-r--r--dev-python/pyilmbase/Manifest1
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.2.0-configure-boost_python.patch22
-rw-r--r--dev-python/pyilmbase/metadata.xml16
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.2.0.ebuild53
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/pyilmbase/Manifest b/dev-python/pyilmbase/Manifest
new file mode 100644
index 000000000000..ae18ecee0256
--- /dev/null
+++ b/dev-python/pyilmbase/Manifest
@@ -0,0 +1 @@
+DIST pyilmbase-2.2.0.tar.gz 469927 SHA256 68c968fec5c40930a2c692ccc88990faa50320ed74b88553a3632d7d02c87e1a SHA512 111deb65a73b4d0454454d4fb64d09165fb25aad2e5714e35510c2b7ef301dc8765041de3188c2f89c9bd2770494a55a24372953fcda8dcedb23c401137e4344 WHIRLPOOL 7992b2f69b78076bca2bf0733b8db11473d0efef3f0b459859a54c5ba4efc47095ad8c05c9e542c1ab57aa5b1a3e285438d4a311daacfed5fb9f19bc8e44e4c3
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.2.0-configure-boost_python.patch b/dev-python/pyilmbase/files/pyilmbase-2.2.0-configure-boost_python.patch
new file mode 100644
index 000000000000..897bc02baf90
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.2.0-configure-boost_python.patch
@@ -0,0 +1,22 @@
+diff --git a/configure.ac b/configure.ac
+index a4d6027..edfb49f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -76,7 +76,7 @@ LIBS="$LIBS -lpython$PYTHON_VERSION"
+ BOOST_PYTHON_CXXFLAGS=""
+ BOOST_PYTHON_LDFLAGS=""
+ BOOST_PYTHON_LIBS=""
+-BOOST_PYTHON_LIBNAME="boost_python"
++BOOST_PYTHON_LIBNAME="boost_python-$PYTHON_VERSION"
+
+ AC_ARG_WITH(
+ [boost-include-dir],
+@@ -90,7 +90,7 @@ AC_ARG_WITH(
+
+ AC_ARG_WITH(
+ [boost-python-libname],
+- [AS_HELP_STRING([--with-boost-python-libname],["boost::python library name (default: boost_python)"])],
++ [AS_HELP_STRING([--with-boost-python-libname],["boost::python library name (default: boost_python-$PYTHON_VERSION)"])],
+ [BOOST_PYTHON_LIBNAME="$withval"])
+
+ CXXFLAGS="$CXXFLAGS $BOOST_PYTHON_CXXFLAGS -I$PYTHON_INC_DIR"
diff --git a/dev-python/pyilmbase/metadata.xml b/dev-python/pyilmbase/metadata.xml
new file mode 100644
index 000000000000..73126d2e6640
--- /dev/null
+++ b/dev-python/pyilmbase/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>waebbl@gmail.com</email>
+ <name>Bernd Waibel</name>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+<longdescription>Provides python bindings for <pkg>media-libs/ilmbase</pkg></longdescription>
+<use>
+ <flag name="numpy">Add bindings for <pkg>dev-python/numpy</pkg> use.</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-python/pyilmbase/pyilmbase-2.2.0.ebuild b/dev-python/pyilmbase/pyilmbase-2.2.0.ebuild
new file mode 100644
index 000000000000..bf77c879e00c
--- /dev/null
+++ b/dev-python/pyilmbase/pyilmbase-2.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils autotools python-single-r1 multilib-minimal
+
+DESCRIPTION="ilmbase Python bindings"
+HOMEPAGE="http://www.openexr.com"
+SRC_URI="http://download.savannah.gnu.org/releases/openexr/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+numpy"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEP}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+RDEPEND="
+ ${PYTHON_DEP}
+ >=media-libs/ilmbase-${PV}:=[${MULTILIB_USEDEP}]
+ >=dev-libs/boost-1.62.0-r1[${MULTILIB_USEDEP},python(+),${PYTHON_USEDEP}]
+ numpy? ( >=dev-python/numpy-1.10.4 )"
+
+AT_M4DIR=m4
+PATCHES=(
+ "${FILESDIR}/${P}-configure-boost_python.patch"
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf "$(use_with numpy numpy)"
+}
+
+# fails to install successfully if MAKEOPTS is set to use more than one core.
+multilib_src_install() {
+ EMAKE_SOURCE=${S} emake DESTDIR="${D}" -j1 install
+}