summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-30 06:50:18 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-30 07:02:35 +0200
commit353fe414b7f7916955ccce1268951ef0ee200486 (patch)
treedb5026e12c85a815495e9888aa2086378d9ff981
parentdev-python/pallets-sphinx-themes: Bump to 2.1.3 (diff)
downloadgentoo-353fe414b7f7916955ccce1268951ef0ee200486.tar.gz
gentoo-353fe414b7f7916955ccce1268951ef0ee200486.tar.bz2
gentoo-353fe414b7f7916955ccce1268951ef0ee200486.zip
dev-python/Faker: Bump to 25.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Faker/Faker-25.0.0.ebuild43
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-25.0.0.ebuild b/dev-python/Faker/Faker-25.0.0.ebuild
new file mode 100644
index 000000000000..6677ad70e7c8
--- /dev/null
+++ b/dev-python/Faker/Faker-25.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ local EPYTEST_DESELECT=(
+ tests/providers/test_job.py::TestCsCZ::test_job
+ )
+ epytest
+}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index aea51bc45180..1ced5c733faa 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -2,3 +2,4 @@ DIST Faker-24.11.0.tar.gz 1726502 BLAKE2B 52429b5b0db4e1fd55d2a4b30ed007417f37e3
DIST Faker-24.14.0.tar.gz 1732995 BLAKE2B 809773a97b417827db72172c3ba68ccf814974771abfde1609087369667b2889c7c118c2b1f4d250c2d67252c33e384d1bc0048f7bb7c5ae790a62486650b4aa SHA512 d767d4e7c7bb96b137f82f51c20dd211b1d94c79384bdcf81f73591e68457e51f884103c6a0569264712bad334774e8f0a909e94d028b9c2ec741211ea69e77b
DIST Faker-24.14.1.tar.gz 1759770 BLAKE2B e58feb12255de946b6c10cd9e3098f4423a47554e6aafcabb1094c7aab7e0dbbd2eea2077411094611c64b92307060c5da383390dc4a14545a9fe54b654e20e7 SHA512 d6afa8c25fe223999bdc776a7c2c12c43e9ad5886d6bb4744fe29c8b358def151b251a37a74a8576e5daedae360c19146f870a1438b63763ffb74b1577a5ae2f
DIST Faker-24.8.0.tar.gz 1725365 BLAKE2B b2646766b993d946bf7965133b7484408370a2e8bed9091b713ffd427d545bb708027066b6787a78cd675659b4d342ac86c9f611aecfb7df3d0565a8066925f0 SHA512 d8fe7e411052bec485b40540317c88ff5aeae8a32ef2e53214816b190d4730c9f5af9157ac2c66aba5fbc887e995d0238f71deefdcf67300e49586c7995b60ff
+DIST Faker-25.0.0.tar.gz 1759596 BLAKE2B f7e89a25579f075ef52ac45f77cc7844bbc9ee910b2568ca813e137b2b2dfafd81c39c2426e1078fc26f5d779115a93a4f4c0361992180eee07dd3d1bbac5e8a SHA512 07a7d9147b0a1084d37bf3fc703dba1504fd2ed4f641a7fc0c0bdca2cd79075d6d10c9cf6d09e95ab93ef2477de890ba08b9bfa25d2305520d41c22a70c08b3b