summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-23 21:24:36 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-23 21:24:52 +1200
commit3541de3fb503f9396eba5a073043cc1283ac4584 (patch)
tree1f4492f12c6f5fae3373b2b3a6de4451d0dc6a96
parentdev-ruby/file-tail: avoid test with race condition (diff)
downloadgentoo-3541de3f.tar.gz
gentoo-3541de3f.tar.bz2
gentoo-3541de3f.zip
dev-perl/Class-Accessor-Lite: -r bump for EAPI7 and minor fixes
- EAPI7 - Add license note - Migrate "sed" to "patch" - Remove empty/unused variable assignments Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Class-Accessor-Lite/Class-Accessor-Lite-0.80.0-r1.ebuild18
-rw-r--r--dev-perl/Class-Accessor-Lite/files/Class-Accessor-Lite-0.08-no-dot-inc.patch22
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Class-Accessor-Lite/Class-Accessor-Lite-0.80.0-r1.ebuild b/dev-perl/Class-Accessor-Lite/Class-Accessor-Lite-0.80.0-r1.ebuild
new file mode 100644
index 000000000000..88d790529c84
--- /dev/null
+++ b/dev-perl/Class-Accessor-Lite/Class-Accessor-Lite-0.80.0-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KAZUHO
+DIST_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="A minimalistic variant of Class::Accessor"
+# License note: perl X.y or later perl X
+# https://bugs.gentoo.org/718946#c5
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+BDEPEND=">=virtual/perl-ExtUtils-MakeMaker-6.360.0"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.08-no-dot-inc.patch"
+)
diff --git a/dev-perl/Class-Accessor-Lite/files/Class-Accessor-Lite-0.08-no-dot-inc.patch b/dev-perl/Class-Accessor-Lite/files/Class-Accessor-Lite-0.08-no-dot-inc.patch
new file mode 100644
index 000000000000..d724a7872b00
--- /dev/null
+++ b/dev-perl/Class-Accessor-Lite/files/Class-Accessor-Lite-0.08-no-dot-inc.patch
@@ -0,0 +1,22 @@
+From 8623694ee180732cbcc1e8dcc9225da850d91b24 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 23 May 2020 21:19:49 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index cdc11bb..08b392f 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,4 +1,5 @@
+ use strict;
++use lib '.';
+ use inc::Module::Install;
+
+ name('Class-Accessor-Lite');
+--
+2.26.2
+