summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-08-21 15:07:00 +0200
committerGuilherme Amadio <amadio@gentoo.org>2021-09-02 11:28:05 +0200
commit354d520135f968f6b3dcfdcd168773e26419f95a (patch)
treedb55f023062a870bb8af847c0c9a655161db4659
parentnet-fs/samba: Bump to version 4.15.0_rc4. Removed old (diff)
downloadgentoo-354d5201.tar.gz
gentoo-354d5201.tar.bz2
gentoo-354d5201.zip
Move sci-physics/{geant-vmc → geant4_vmc}
This follows the new consistent naming of the upstream project, collapsing the first version number into the package name. Closes: https://github.com/gentoo/gentoo/pull/22068 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
-rw-r--r--profiles/updates/3Q-20211
-rw-r--r--sci-physics/geant-vmc/Manifest1
-rw-r--r--sci-physics/geant4_vmc/Manifest1
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-5.3-r1.ebuild (renamed from sci-physics/geant-vmc/geant-vmc-4.5.3-r1.ebuild)8
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-9999.ebuild (renamed from sci-physics/geant-vmc/geant-vmc-9999.ebuild)8
-rw-r--r--sci-physics/geant4_vmc/metadata.xml (renamed from sci-physics/geant-vmc/metadata.xml)0
-rw-r--r--sci-physics/vgm/vgm-4.8-r1.ebuild2
-rw-r--r--sci-physics/vgm/vgm-4.9-r1.ebuild2
-rw-r--r--sci-physics/vgm/vgm-9999.ebuild2
9 files changed, 13 insertions, 12 deletions
diff --git a/profiles/updates/3Q-2021 b/profiles/updates/3Q-2021
index 0e75a5958bb4..59da6b5d43f4 100644
--- a/profiles/updates/3Q-2021
+++ b/profiles/updates/3Q-2021
@@ -8,3 +8,4 @@ move dev-python/python-backoff dev-python/backoff
move dev-python/python-musicbrainz-ngs dev-python/python-musicbrainzngs
move dev-python/python-podman dev-python/podman-py
move dev-python/u-msgpack dev-python/u-msgpack-python
+move sci-physics/geant-vmc sci-physics/geant4_vmc
diff --git a/sci-physics/geant-vmc/Manifest b/sci-physics/geant-vmc/Manifest
deleted file mode 100644
index f28791df07e5..000000000000
--- a/sci-physics/geant-vmc/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST geant-vmc-4.5.3.tar.gz 7411643 BLAKE2B 31a486aa32f879093753aab09798eabf1a936f0aa246bb97c7f055eefb789c9c5a5097c14ce47b05a99f3cc2b46bea6edeba2af80ee362bb8fee039ee711eddc SHA512 918ce3ca4a4fb329f00000fce00dae3d4a4c9f348553f31bf474f727c1e67242b5ff28fe7dc5d3ab12d1174663b1dd96b654b5baf7edfa662ab3f66687792e94
diff --git a/sci-physics/geant4_vmc/Manifest b/sci-physics/geant4_vmc/Manifest
new file mode 100644
index 000000000000..ddfb4b445a2e
--- /dev/null
+++ b/sci-physics/geant4_vmc/Manifest
@@ -0,0 +1 @@
+DIST geant4_vmc-5.3.tar.gz 7411643 BLAKE2B 31a486aa32f879093753aab09798eabf1a936f0aa246bb97c7f055eefb789c9c5a5097c14ce47b05a99f3cc2b46bea6edeba2af80ee362bb8fee039ee711eddc SHA512 918ce3ca4a4fb329f00000fce00dae3d4a4c9f348553f31bf474f727c1e67242b5ff28fe7dc5d3ab12d1174663b1dd96b654b5baf7edfa662ab3f66687792e94
diff --git a/sci-physics/geant-vmc/geant-vmc-4.5.3-r1.ebuild b/sci-physics/geant4_vmc/geant4_vmc-5.3-r1.ebuild
index cafdbf75e099..503e3d2f17a6 100644
--- a/sci-physics/geant-vmc/geant-vmc-4.5.3-r1.ebuild
+++ b/sci-physics/geant4_vmc/geant4_vmc-5.3-r1.ebuild
@@ -7,11 +7,11 @@ inherit cmake
if [[ ${PV} == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/vmc-project/geant4_vmc.git"
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
else
- MY_PV=$(ver_rs 1-2 - $(ver_cut 2-))
- SRC_URI="https://github.com/vmc-project/geant4_vmc/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/geant4_vmc-${MY_PV}"
+ MY_PV=$(ver_rs 1- -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
KEYWORDS="~amd64 ~x86"
fi
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
index b22fc0afcbf8..e5a8d12edb26 100644
--- a/sci-physics/geant-vmc/geant-vmc-9999.ebuild
+++ b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
@@ -7,11 +7,11 @@ inherit cmake
if [[ ${PV} == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/vmc-project/geant4_vmc.git"
+ EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
else
- MY_PV=$(ver_rs 1-2 - $(ver_cut 2-))
- SRC_URI="https://github.com/vmc-project/geant4_vmc/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/geant4_vmc-${MY_PV}"
+ MY_PV=$(ver_rs 1- -)
+ SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
KEYWORDS="~amd64 ~x86"
fi
diff --git a/sci-physics/geant-vmc/metadata.xml b/sci-physics/geant4_vmc/metadata.xml
index 7fc023bcb29a..7fc023bcb29a 100644
--- a/sci-physics/geant-vmc/metadata.xml
+++ b/sci-physics/geant4_vmc/metadata.xml
diff --git a/sci-physics/vgm/vgm-4.8-r1.ebuild b/sci-physics/vgm/vgm-4.8-r1.ebuild
index 2719bc7a3502..0b5ee6471a34 100644
--- a/sci-physics/vgm/vgm-4.8-r1.ebuild
+++ b/sci-physics/vgm/vgm-4.8-r1.ebuild
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? (
sci-physics/geant[gdml]
- sci-physics/geant-vmc[g4root]
+ sci-physics/geant4_vmc[g4root]
)"
RESTRICT="
!geant4? ( test )
diff --git a/sci-physics/vgm/vgm-4.9-r1.ebuild b/sci-physics/vgm/vgm-4.9-r1.ebuild
index b7b9482e355c..b9d0ad2bcca2 100644
--- a/sci-physics/vgm/vgm-4.9-r1.ebuild
+++ b/sci-physics/vgm/vgm-4.9-r1.ebuild
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? (
sci-physics/geant[gdml]
- sci-physics/geant-vmc[g4root]
+ sci-physics/geant4_vmc[g4root]
)"
RESTRICT="
!geant4? ( test )
diff --git a/sci-physics/vgm/vgm-9999.ebuild b/sci-physics/vgm/vgm-9999.ebuild
index bd7c83ff458e..a2b21203209d 100644
--- a/sci-physics/vgm/vgm-9999.ebuild
+++ b/sci-physics/vgm/vgm-9999.ebuild
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? (
sci-physics/geant[gdml]
- sci-physics/geant-vmc[g4root]
+ sci-physics/geant4_vmc[g4root]
)"
RESTRICT="
!geant4? ( test )