summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-05-01 07:34:45 +0200
committerHans de Graaff <graaff@gentoo.org>2024-05-01 08:36:30 +0200
commit355269bfda01c82499dbfbaee7d03b55692d6c5b (patch)
tree1727adcd7d6fb0be1a48e31bf1a075458797727a
parentdev-build/meson: Stabilize 1.4.0-r1 ppc64, #930997 (diff)
downloadgentoo-355269bfda01c82499dbfbaee7d03b55692d6c5b.tar.gz
gentoo-355269bfda01c82499dbfbaee7d03b55692d6c5b.tar.bz2
gentoo-355269bfda01c82499dbfbaee7d03b55692d6c5b.zip
dev-ruby/multi_xml: add 0.7.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/multi_xml/Manifest1
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.7.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/multi_xml/Manifest b/dev-ruby/multi_xml/Manifest
index 783212feca59..3d6d37c07f1e 100644
--- a/dev-ruby/multi_xml/Manifest
+++ b/dev-ruby/multi_xml/Manifest
@@ -1 +1,2 @@
DIST multi_xml-0.6.0.tar.gz 16571 BLAKE2B 1492eab7782823915167ebdb529b6d4699b31f3b66c48eee5acf7857dc25caae62b63a0da10a0bd862ade22865432bc6c4290a3f6ff8e99a889fcf09b56f6b7f SHA512 67e280d838ba07373a6ad5cbe4658b32655102906d8e0ed5429d21220475c21e07ea2ec0d2729df4d30a1bf7d0a5e6ff2d4482342098873135cb12e18c53194a
+DIST multi_xml-0.7.0.tar.gz 17139 BLAKE2B 8b1e8352a8e7e5860d08e0ebe7bf65b2e5b0213371066c6e3a83515164c865c8db3ab4a4918dd3e8f9e5f73f6bc5fedee1cf2ec710e84303c365d335ade3d06e SHA512 d05a1b387c5a29445a71a838a24f1ac782c01dbaa41785a5c0375f72d8c3ec6d59f0ee5eed64e327282fc47390c08bdd602beb83b657e771844f6d740a75d3d5
diff --git a/dev-ruby/multi_xml/multi_xml-0.7.0.ebuild b/dev-ruby/multi_xml/multi_xml-0.7.0.ebuild
new file mode 100644
index 000000000000..fdfcb1a2ba9c
--- /dev/null
+++ b/dev-ruby/multi_xml/multi_xml-0.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generic swappable back-end for XML parsing"
+HOMEPAGE="https://www.rubydoc.info/gems/multi_xml"
+SRC_URI="https://github.com/sferik/multi_xml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/bigdecimal-3.1:0"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/ox )"
+
+all_ruby_prepare() {
+ sed -e 's:_relative ": "./:' \
+ -e 's/__dir__/"."/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die
+ sed -e '/bundler/I s:^:#:' \
+ -e '/yardstick/,/end/ s:^:#:' \
+ -e '/rubocop/I s:^:#:' \
+ -i Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}