summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-29 06:57:54 +0000
committerSam James <sam@gentoo.org>2024-02-29 07:03:29 +0000
commit35606cd7f9fb29a4c83847cfc00ef364f85287a8 (patch)
treeac18b7fa6a681edba88a25601ce35f3efc9a9167
parentsci-electronics/kicad: add depend app-crypt/libsecret (diff)
downloadgentoo-35606cd7f9fb29a4c83847cfc00ef364f85287a8.tar.gz
gentoo-35606cd7f9fb29a4c83847cfc00ef364f85287a8.tar.bz2
gentoo-35606cd7f9fb29a4c83847cfc00ef364f85287a8.zip
dev-libs/npth: fix musl build
Closes: https://bugs.gentoo.org/925443 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/npth/files/npth-1.7-musl.patch16
-rw-r--r--dev-libs/npth/npth-1.7-r1.ebuild4
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/npth/files/npth-1.7-musl.patch b/dev-libs/npth/files/npth-1.7-musl.patch
new file mode 100644
index 000000000000..5b51a3fd4a28
--- /dev/null
+++ b/dev-libs/npth/files/npth-1.7-musl.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/925443
+https://dev.gnupg.org/T5664
+--- a/configure.ac
++++ b/configure.ac
+@@ -381,7 +381,10 @@ fi
+ AC_SUBST(INSERT_NO_RWLOCK)
+
+ case "${host}" in
+- *-*-linux*|*-*-gnu*)
++ *-*-linux-musl*)
++ INSERT_EXPOSE_RWLOCK_API="1"
++ ;;
++ *-*-linux-gnu*|*-*-gnu*)
+ INSERT_EXPOSE_RWLOCK_API="defined(__USE_UNIX98) || defined(__USE_XOPEN2K)"
+ ;;
+ *)
diff --git a/dev-libs/npth/npth-1.7-r1.ebuild b/dev-libs/npth/npth-1.7-r1.ebuild
index d390d9c7bb59..04b867400ad5 100644
--- a/dev-libs/npth/npth-1.7-r1.ebuild
+++ b/dev-libs/npth/npth-1.7-r1.ebuild
@@ -15,6 +15,10 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~
IUSE="test"
RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}"/${P}-musl.patch
+)
+
src_prepare() {
default
eautoreconf