summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-08-28 21:40:37 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-28 21:40:37 +0200
commit356cbf5897e9b49b0befe71e61e1f6961ff7f1cc (patch)
tree22d92041e0f01991546b48206cce8ff1a789d7df
parentapp-vim/ackvim: Stable for amd64. Retroactively mark stable for the remaining... (diff)
downloadgentoo-356cbf58.tar.gz
gentoo-356cbf58.tar.bz2
gentoo-356cbf58.zip
app-vim/vimcalc: add missing die.
Package-Manager: portage-2.2.28
-rw-r--r--app-vim/vimcalc/vimcalc-1.3-r2.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-vim/vimcalc/vimcalc-1.3-r2.ebuild b/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
index 297c20ddb6f9..674319eb0277 100644
--- a/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
+++ b/app-vim/vimcalc/vimcalc-1.3-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit python-single-r1 vim-plugin
@@ -15,17 +16,21 @@ KEYWORDS="~amd64 ~x86"
VIM_PLUGIN_HELPFILES="vimcalc"
-DEPEND="app-arch/unzip
+DEPEND="
+ app-arch/unzip
${PYTHON_DEPS}"
-RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+
+RDEPEND="
+ || ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
${PYTHON_DEPS}"
+
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
S="${WORKDIR}/${PN}-v${PV}"
src_prepare() {
# Remove .DS_Store files that should not be installed
- find -type f -name '.DS*' -delete
+ find -type f -name '.DS*' -delete || die
}
src_test() {