summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 13:33:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 14:24:43 +0200
commit356ff41bb9b806651578b175bd527db99c404d7c (patch)
treeb78af0dd531b157fb5ecb2678e0f57131df46b6b
parentdev-ml/reason: Initial import. Ebuild by me. (diff)
downloadgentoo-356ff41b.tar.gz
gentoo-356ff41b.tar.bz2
gentoo-356ff41b.zip
dev-ml/easy-format: Bump to 1.2.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ml/easy-format/Manifest1
-rw-r--r--dev-ml/easy-format/easy-format-1.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/easy-format/Manifest b/dev-ml/easy-format/Manifest
index 67578a6d17b8..185bcbcf8d9d 100644
--- a/dev-ml/easy-format/Manifest
+++ b/dev-ml/easy-format/Manifest
@@ -1 +1,2 @@
DIST easy-format-1.0.2.tar.gz 13679 SHA256 f1e763a3b5962b87698786f5e1e17e46311106dc76fd2e2ef822cd8df37d941f SHA512 bb12c13b33a725f4a15616672f7a268398b50e6f054575203f1d26c49aa04978564233fa9fb88eec8b701d7fecbbaeda264422e8c31a60a52d0d8e64bfc5898f WHIRLPOOL 648472cd06aae2b6003e4e827dfd801e7f103d08458e0a6639d57ab938195b30821a74db28f3a14e44521108d1ea323a6e084c589a64279f76f05e028da4922f
+DIST easy-format-1.2.0.tar.gz 15632 SHA256 a288fabcdc19c2262e76cf93e0fd987fe1b21493edd13309522fbae405329ffd SHA512 375849b1ecd2e37f4b32d1ee12197a95856b17a47e3eb06a7e7320a82234c241156c3c8bfb18ce17bbe73b93d31d755675478860505470aa7ab866277a99603f WHIRLPOOL 0060758c100c5183978223f69286b9193f557d08ec1a4fa1594c37b993722dfda70e737f56b44b4d5ffebfc19fca93bf3417dfbba0b2b19e214ebc0a92f597eb
diff --git a/dev-ml/easy-format/easy-format-1.2.0.ebuild b/dev-ml/easy-format/easy-format-1.2.0.ebuild
new file mode 100644
index 000000000000..669c69092068
--- /dev/null
+++ b/dev-ml/easy-format/easy-format-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/mjambon/easy-format"
+SRC_URI="https://github.com/mjambon/easy-format/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples +ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}