summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-01 07:03:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-01 08:09:09 +0100
commit357c08c7882099f11c5b78f3faa14b8dbe3d5d9b (patch)
tree33d7bf642b9fbd81ffd2f766179e451b0794fdea
parentdev-python/moto: Bump to 4.0.11 (diff)
downloadgentoo-357c08c7882099f11c5b78f3faa14b8dbe3d5d9b.tar.gz
gentoo-357c08c7882099f11c5b78f3faa14b8dbe3d5d9b.tar.bz2
gentoo-357c08c7882099f11c5b78f3faa14b8dbe3d5d9b.zip
dev-python/path: Bump to 16.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/path/Manifest1
-rw-r--r--dev-python/path/path-16.6.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 5b3e7e0653d5..e8d0b73d9c50 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1 +1,2 @@
DIST path-16.5.0.gh.tar.gz 44286 BLAKE2B 1d96b0003c562044c1c2ba5eba7a525d5503bd9a58ec1f9611d74e9d52581f646447d3d754809b49b4418c18de9fbfd5de34077fe9edb1c4b3d3fd49f9c2af19 SHA512 0b9b306b2b5cce1e51d65a7555e54770e19a3d4796dbaf2d617bbe8282c771e3d7975112e443462e9b43bafc533d6dc61bedb8608b0d93cc0d1febec995d1780
+DIST path-16.6.0.gh.tar.gz 45238 BLAKE2B f1fa3a23ba19f623ca276496c1fa7351ea02858710f2dddbf5f4d96cf2c9f8fc3325c74a56f1b4dec809e28e927f2c8adab913eed9d8893016e0fd3d0b3a662d SHA512 4d7772b7eb7017bee78f95f30f6286b14750d6d8edbf5f58617ede12bd664f1b893921b89bb64f797e1d2eb7e67e361d8f1e01618fee26d64a5b879a3854aead
diff --git a/dev-python/path/path-16.6.0.ebuild b/dev-python/path/path-16.6.0.ebuild
new file mode 100644
index 000000000000..ecd7e2ae4fa3
--- /dev/null
+++ b/dev-python/path/path-16.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+SRC_URI="
+ https://github.com/jaraco/path/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}