summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-01-21 01:28:07 -0300
committerMatt Turner <mattst88@gentoo.org>2023-01-22 22:57:46 -0500
commit357f865592a47c18bda7eeb82335ef6b5777e430 (patch)
tree2643d6063d4e5fe970fd92204d49d2615d9fd027
parentapp-editors/gedit-plugins: Version bump to 44.1 (diff)
downloadgentoo-357f865592a47c18bda7eeb82335ef6b5777e430.tar.gz
gentoo-357f865592a47c18bda7eeb82335ef6b5777e430.tar.bz2
gentoo-357f865592a47c18bda7eeb82335ef6b5777e430.zip
x11-libs/goffice: Version bump to 0.10.54
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29198 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/goffice/Manifest1
-rw-r--r--x11-libs/goffice/goffice-0.10.54.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 1b09baf5bc12..048fee85dfd3 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1 +1,2 @@
DIST goffice-0.10.53.tar.xz 2442336 BLAKE2B 8fda50c5d9f8223c082ea9f03334313b051bce47d18b3879c2d8a7c2bbce753f468b5135f0a3c49c54b8a695ee6f1dc355dc806c92e77f41f2d0c64b2bc30bf0 SHA512 cd2d0f49f803cb2f01b3a690bfbe3ea4be5c09e00e8ef643055f56c16549529b7c2c098b87286062d3a5048c1f64d600f74082f53710d8ed8cbb34cb6829dafd
+DIST goffice-0.10.54.tar.xz 2443132 BLAKE2B 83ded093730e214b0d20563789ce13aa959d14fd0911068898afcfe7eaa61f1d42a9aa0e97124a7df585474a290414f077d0fbcfc916e7b41726c56215f16fa6 SHA512 d2c23b211bf5d7148a72e6f76629590418e776f789b763fd234f9008e7e8138e6e4077e2c5ecaf6893b944ee1725899aa89544342b0a8bdf3efde4833ca53304
diff --git a/x11-libs/goffice/goffice-0.10.54.ebuild b/x11-libs/goffice/goffice-0.10.54.ebuild
new file mode 100644
index 000000000000..9e1f7c7809f9
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.54.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org libtool
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libxml2-2.4.12:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=x11-libs/cairo-1.10:=[svg(+)]
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/pango-1.24:=
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ dodoc MAINTAINERS
+
+ find "${ED}" -name '*.la' -delete || die
+}