summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-18 06:45:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-18 06:52:23 +0200
commit35830d805f07c6e12c454c7afe8a2c207d3d74ad (patch)
tree226d9977fc78c60b5f8cdd45320ff005898a9d66
parentdev-python/pytest-localftpserver: Bump to 1.3.1 (diff)
downloadgentoo-35830d805f07c6e12c454c7afe8a2c207d3d74ad.tar.gz
gentoo-35830d805f07c6e12c454c7afe8a2c207d3d74ad.tar.bz2
gentoo-35830d805f07c6e12c454c7afe8a2c207d3d74ad.zip
dev-python/cfn-lint: Bump to 0.87.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.87.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index d5283f7f1774..5bf72eff4b64 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn_lint-0.86.4.tar.gz 3911739 BLAKE2B ea2d58abb78b466371b5a65cda2f5fd06f31eb16eece4d5bb3741f166e0bfb54d35c5d6605f5d9b333876fa1a85916f0aaecab5f0b0bd6b29841a2b5e813ed09 SHA512 71b50058ccdbcccedc92b70ca1af4c5163feb26415a97afad6e39761645423259b4dcdb6a24b517ba494e7474b31909d44399461c6d19834791d5057b14ef886
DIST cfn_lint-0.87.1.tar.gz 3997592 BLAKE2B 058de8badb0b37bda16e5239a2d9aa3727804bc9bd1b308cf9225c4b650eb6d0ad184025eee9e32ac9909db429641a8c928695be9c1a0cf587cffbf4f50dcba2 SHA512 3143d23738de9435c63b1f7f6f8abcea9fa235e45c885f15869a18a67089421094f77b5f4dd472f354f2901595bf1d0c2ef66f5605ff5ebc1ebbdbdca181d6bf
DIST cfn_lint-0.87.2.tar.gz 3963369 BLAKE2B e1238db45fa2856ed1becdbaeccd2bd7aab3c0c3f54e3bd13cdad27d20c0c9e0c85a232121f63b152554f95066cf24119b9e2c02d0402d673ed5d7eefc8565ed SHA512 b0503138d7ca939003b472ce0e35ae0f0c3aa9550cc889e28a709856051d059c619c2ac5d47735ce0702cb975949d6ea64aff6c2b5168738ccf8afbcf950801d
+DIST cfn_lint-0.87.3.tar.gz 3963065 BLAKE2B 400532698248204fe2bbf9f29fb374d178cd4a8b168dcb681b284da0d5d7be17cd28292b8f37a7c600936b96a56e90d925e5e0d88f062f5c8a7821f0ffe43528 SHA512 b23ed7259907da993469b4b2a6cfb6a5b8f1bc9186d65e8392ccf628b8b37fe7a0bde6d5d57ca6924d738770367e67245f13abce4777fa88945316569eb59b4b
diff --git a/dev-python/cfn-lint/cfn-lint-0.87.3.ebuild b/dev-python/cfn-lint/cfn-lint-0.87.3.ebuild
new file mode 100644
index 000000000000..ccd32235036e
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.87.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.87.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}