summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-02-19 10:44:47 +0000
committerSam James <sam@gentoo.org>2022-02-20 00:30:46 +0000
commit3593f952ae981bc25e6486b04bda7fff196edcdd (patch)
tree113cd5458a3369335a1113be99d1494b41e7c051
parentwww-apache/mod_security: keep unicode.mapping (diff)
downloadgentoo-3593f952ae981bc25e6486b04bda7fff196edcdd.tar.gz
gentoo-3593f952ae981bc25e6486b04bda7fff196edcdd.tar.bz2
gentoo-3593f952ae981bc25e6486b04bda7fff196edcdd.zip
www-apache/mod_security: drop old
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24272 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-apache/mod_security/Manifest1
-rw-r--r--www-apache/mod_security/mod_security-2.9.3-r100.ebuild124
2 files changed, 0 insertions, 125 deletions
diff --git a/www-apache/mod_security/Manifest b/www-apache/mod_security/Manifest
index 00ae4fe3e6fb..b6b9c755e5f7 100644
--- a/www-apache/mod_security/Manifest
+++ b/www-apache/mod_security/Manifest
@@ -1,2 +1 @@
-DIST modsecurity-2.9.3.tar.gz 4307670 BLAKE2B 337ea15cc8805af7ab43aed8aecf4c72ccc586d0d7e9d9b91f036a61baa70d1ac8b4ad8045a2bb7a13515912a15fba7d3cdb9670ae6730de43b1e44ee90ded6d SHA512 4e1ea5dd8edadf8f630e4fe92a200d3a8e78963fce3128b5975a1e1ecd0e8bf9ceecd9905c95f8c508932ccd837f1d8ae8bb2ba423307718c3c6a4ae9b783ddd
DIST modsecurity-2.9.5.tar.gz 4315037 BLAKE2B f6e607f344038c74fbbacbba6bbeb5953a7ab13b54d140924f4fe586a1506720d383285e7ce68dc9386f3532d298d53de55446f336c4b2f3e359bf8636bba0d0 SHA512 eef10afbce7407038b12d3c94213a17ecadf2db9a39f15006809848717f9a0d53d52f050957e13725e972191106c54eafb8915d564e5f0756a8a93c84048a4df
diff --git a/www-apache/mod_security/mod_security-2.9.3-r100.ebuild b/www-apache/mod_security/mod_security-2.9.3-r100.ebuild
deleted file mode 100644
index ad8579ac88e7..000000000000
--- a/www-apache/mod_security/mod_security-2.9.3-r100.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..3} )
-
-inherit autotools apache-module lua-single
-
-MY_PN=modsecurity
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Application firewall and intrusion detection for Apache"
-HOMEPAGE="https://www.modsecurity.org/"
-SRC_URI="https://www.modsecurity.org/tarball/${PV}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc fuzzyhash geoip jit json lua mlogc"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-COMMON_DEPEND="dev-libs/apr
- dev-libs/apr-util[openssl]
- dev-libs/libxml2
- dev-libs/libpcre[jit?]
- fuzzyhash? ( app-crypt/ssdeep )
- json? ( dev-libs/yajl )
- lua? ( ${LUA_DEPS} )
- mlogc? ( net-misc/curl )
- www-servers/apache[apache2_modules_unique_id]"
-BDEPEND="doc? ( app-doc/doxygen )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}
- geoip? ( dev-libs/geoip )
- mlogc? ( dev-lang/perl )"
-PDEPEND=">=www-apache/modsecurity-crs-2.2.6-r1"
-
-S="${WORKDIR}/${MY_P}"
-
-APACHE2_MOD_FILE="apache2/.libs/${PN}2.so"
-APACHE2_MOD_CONF="79_${PN}"
-APACHE2_MOD_DEFINE="SECURITY"
-
-# Tests require symbols only defined within the Apache binary.
-RESTRICT=test
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.9.3-autoconf_lua_package_name.patch
-)
-
-need_apache2
-
-pkg_setup() {
- _init_apache2
- _init_apache2_late
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- --disable-static
- --enable-request-early
- --with-apxs="${APXS}"
- --with-pic
- $(use_with fuzzyhash ssdeep)
- $(use_with json yajl)
- $(use_enable mlogc)
- $(use_with lua)
- $(use_enable lua lua-cache)
- $(use_enable jit pcre-jit)
- $(use_enable doc docs) )
-
- econf ${myconf[@]}
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- apache-module_src_install
-
- dodoc CHANGES README.md modsecurity.conf-recommended
-
- if use doc; then
- dodoc -r doc/apache/html
- fi
-
- if use mlogc; then
- insinto /etc/
- newins mlogc/mlogc-default.conf mlogc.conf
- dobin mlogc/mlogc
- dobin mlogc/mlogc-batch-load.pl
- newdoc mlogc/INSTALL INSTALL-mlogc
- fi
-
- # Use /var/lib instead of /var/cache. This stuff is "persistent,"
- # and isn't a cached copy of something that we can recreate.
- # Bug 605496.
- keepdir /var/lib/modsecurity
- fowners apache:apache /var/lib/modsecurity
- fperms 0750 /var/lib/modsecurity
- for dir in data tmp upload; do
- keepdir "/var/lib/modsecurity/${dir}"
- fowners apache:apache "/var/lib/modsecurity/${dir}"
- fperms 0750 "/var/lib/modsecurity/${dir}"
- done
-}
-
-pkg_postinst() {
- elog "The base configuration file has been renamed ${APACHE2_MOD_CONF}"
- elog "so that you can put your own configuration in (for example)"
- elog "90_modsecurity_local.conf."
- elog ""
- elog "That would be the correct place for site-global security rules."
- elog "Note: 80_modsecurity_crs.conf is used by www-apache/modsecurity-crs"
-}