summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-18 07:35:19 +0000
committerSam James <sam@gentoo.org>2021-12-18 07:35:19 +0000
commit3593ff567e7edd7e0967f42ca5e35fe5cc67d882 (patch)
tree0b1f7c7308bf8bb5aef028e8c4f215dab17cfe52
parentsys-libs/libxcrypt: add 4.4.27 (diff)
downloadgentoo-3593ff567e7edd7e0967f42ca5e35fe5cc67d882.tar.gz
gentoo-3593ff567e7edd7e0967f42ca5e35fe5cc67d882.tar.bz2
gentoo-3593ff567e7edd7e0967f42ca5e35fe5cc67d882.zip
dev-util/diffoscope: add 197
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/diffoscope/Manifest1
-rw-r--r--dev-util/diffoscope/diffoscope-197.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 2639fb71ccec..63d1ed49b05c 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -2,3 +2,4 @@ DIST diffoscope-190.tar.gz 2704083 BLAKE2B a2a0313f87fdb9c20b0dc696a1aea570857dd
DIST diffoscope-194.tar.gz 2704634 BLAKE2B ca080f07ab23d48cd772302f47fff67c38ca3106d2fd96de37b9112aa316ec095acb07062316abf60ac3457de99b6e3f69adef166ab4b24943dff9e8a127f99f SHA512 cfdd30ea12326ca08f200a78fd77b5b681bbe31cd292fa22fcab294a64717a06f431bcc8c3def7c75f9fb554108e48b8043bc3901d5e57a2be3cc38d20a303e5
DIST diffoscope-195.tar.gz 2704638 BLAKE2B 7d8caeaaf5d844c85254f017e49544e016ea16c4876623c0eae18c78389195f91ba567c1197ea9d1ccf326a92483be11a189afdd96a334fa8e0f766a7e78fafd SHA512 619517ce1900ba5e3e642ca758767aacf8bb3b58e288710cdb425500e6074135a5d2147a34214b284b94eacb781e790f638c57e1489492eae8c4bd557fce8a4e
DIST diffoscope-196.tar.gz 2704695 BLAKE2B aa53848171ce8ff76bffd1ded4ef5f3fb661960f36137a96d00cec380ef090929b694f2ab33244aea29b35be279ba7a10b513bd8333ea809a495e73f22d4901a SHA512 102ff95e33967e17e7437e4270a072fc526ecc96b7b91fa2d5a6c9cefce4d6905a59d3fcf0e3a6727d3452a1f6f90a1b7f329c8ce0552929ec5b49fec5869692
+DIST diffoscope-197.tar.gz 2705041 BLAKE2B 1d66462d3f1cdbba177d24d194ce14ae51274c6b60139e56724213a6b4fc0b41e6a71f9f2e250ecc7d6330186bf774470b2153801b375ffb63e8390c425e1073 SHA512 d8411ad166738b29caa28abbc10f21e0906b7b19bd5ab644db36c04b1f9c5af9f4cbdb31eb850da7249380a6774bde355f0e815f4d3cdd0df76570df9df7fd0a
diff --git a/dev-util/diffoscope/diffoscope-197.ebuild b/dev-util/diffoscope/diffoscope-197.ebuild
new file mode 100644
index 000000000000..57030d324ef8
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-197.ebuild
@@ -0,0 +1,108 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+)
+
+distutils_enable_tests pytest