summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-10 16:03:39 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-10 16:03:39 -0500
commit35955eb9f11cf884675ef4280cc64af6b4415cbe (patch)
treef0df4eabb9e4a2c85f596c2d12f3645a4f88bdaf
parentnet-analyzer/cacti-spine: Version bump. (diff)
downloadgentoo-35955eb9.tar.gz
gentoo-35955eb9.tar.bz2
gentoo-35955eb9.zip
dev-cpp/yaml-cpp: yaml-cpp makes static links to boost bug 628360
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.5.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.5.3-r1.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..6bf29f127ca7
--- /dev/null
+++ b/dev-cpp/yaml-cpp/yaml-cpp-0.5.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="YAML parser and emitter in C++"
+HOMEPAGE="https://github.com/jbeder/yaml-cpp"
+SRC_URI="https://github.com/jbeder/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.49.0-r2:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
+
+src_prepare() {
+ sed -i \
+ -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
+ yaml-cpp.pc.cmake || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}