summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-10-20 01:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-10-20 16:35:51 -0400
commit35b6880e96552d413b1790e82487f7f78a16b42c (patch)
tree4bcc678d2ec852c8a3e14b2cf05a38a7ab24fece
parentdev-libs/re2: Version bump (0.2020.10.01). (diff)
downloadgentoo-35b6880e96552d413b1790e82487f7f78a16b42c.tar.gz
gentoo-35b6880e96552d413b1790e82487f7f78a16b42c.tar.bz2
gentoo-35b6880e96552d413b1790e82487f7f78a16b42c.zip
dev-util/gyp: Drop support for Python 3.6. Add support for Python 3.9.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-util/gyp/gyp-20200512145953.ebuild10
-rw-r--r--dev-util/gyp/gyp-99999999999999.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/dev-util/gyp/gyp-20200512145953.ebuild b/dev-util/gyp/gyp-20200512145953.ebuild
index 9ee7379992fa..04041f153491 100644
--- a/dev-util/gyp/gyp-20200512145953.ebuild
+++ b/dev-util/gyp/gyp-20200512145953.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
DISTUTILS_SINGLE_IMPL="1"
DISTUTILS_USE_SETUPTOOLS="rdepend"
@@ -35,8 +35,16 @@ python_prepare_all() {
distutils-r1_python_prepare_all
sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
+ sed \
+ -e "s/import collections/import collections.abc/" \
+ -e "s/collections\.MutableSet/collections.abc.MutableSet/" \
+ -i pylib/gyp/common.py || die
sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib/gyp/input.py || die
sed \
+ -e "s/import collections/import collections.abc/" \
+ -e "s/collections\.Iterable/collections.abc.Iterable/" \
+ -i pylib/gyp/msvs_emulation.py || die
+ sed \
-e "s/os\.environ\['PRESERVE'\] is not ''/os.environ['PRESERVE'] != ''/" \
-e "s/conditions is ()/conditions == ()/" \
-i test/lib/TestCmd.py || die
diff --git a/dev-util/gyp/gyp-99999999999999.ebuild b/dev-util/gyp/gyp-99999999999999.ebuild
index bf36a597b2c0..f163e0f3957b 100644
--- a/dev-util/gyp/gyp-99999999999999.ebuild
+++ b/dev-util/gyp/gyp-99999999999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
DISTUTILS_SINGLE_IMPL="1"
DISTUTILS_USE_SETUPTOOLS="rdepend"
@@ -35,8 +35,16 @@ python_prepare_all() {
distutils-r1_python_prepare_all
sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
+ sed \
+ -e "s/import collections/import collections.abc/" \
+ -e "s/collections\.MutableSet/collections.abc.MutableSet/" \
+ -i pylib/gyp/common.py || die
sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib/gyp/input.py || die
sed \
+ -e "s/import collections/import collections.abc/" \
+ -e "s/collections\.Iterable/collections.abc.Iterable/" \
+ -i pylib/gyp/msvs_emulation.py || die
+ sed \
-e "s/os\.environ\['PRESERVE'\] is not ''/os.environ['PRESERVE'] != ''/" \
-e "s/conditions is ()/conditions == ()/" \
-i test/lib/TestCmd.py || die