summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-01 08:25:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-01 09:44:53 +0200
commit35c11215058222f84edcb97f4f8066eddbec596b (patch)
tree501ae3c20bf0127350dfe215dd5a926ff1f93f2c
parentdev-python/line_profiler: Bump to 3.2.5 (diff)
downloadgentoo-35c11215.tar.gz
gentoo-35c11215.tar.bz2
gentoo-35c11215.zip
dev-python/pylast: Bump to 4.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylast/Manifest1
-rw-r--r--dev-python/pylast/pylast-4.2.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pylast/Manifest b/dev-python/pylast/Manifest
index 3ac02696ae01..700dd4feb9c7 100644
--- a/dev-python/pylast/Manifest
+++ b/dev-python/pylast/Manifest
@@ -1 +1,2 @@
DIST pylast-4.2.0.tar.gz 39761 BLAKE2B 35ab18928b2761255a25e2b8549fe852f28f04057c9fb1075fa223333d079c07340ea17d425695d17c0ec99d67e6e31ed93f6fe60df1121ae7c298cca99b1b03 SHA512 9c8c0eea0d3f54514ba06ad7da0868844f8dc53715717decb3b56772093e637673deb22ee4277e508d7e659b48c79733514c67c9af0283e8aa0032caeae3d44f
+DIST pylast-4.2.1.tar.gz 39787 BLAKE2B 1f2f06671ce38bd42f7297279a58f674c3af8f66de4fe804d90e3fc178c73f09a24f65bbc4fd534da0c04f593dc5eb31f03da38a4ca969ea31a04978a603b7b4 SHA512 c1418ff1e6b6ab905d790cc83eb1a4b3172c0c28d523c2bbd641523a2e2601a84aff126dafd047f0fb9b82744bca883648e197b273026611f47671d39afd4fc6
diff --git a/dev-python/pylast/pylast-4.2.1.ebuild b/dev-python/pylast/pylast-4.2.1.ebuild
new file mode 100644
index 000000000000..15fc748bcb74
--- /dev/null
+++ b/dev-python/pylast/pylast-4.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}