summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-12-20 15:33:32 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-12-20 16:06:14 +0100
commit35c496ce213cb2c43c9621b060a58c2e8dcc7036 (patch)
tree53b62e723a9d4cf8ca3e8c7f81879c92f239d0a7
parentdev-python/ws4py: treeclean (diff)
downloadgentoo-35c496ce213cb2c43c9621b060a58c2e8dcc7036.tar.gz
gentoo-35c496ce213cb2c43c9621b060a58c2e8dcc7036.tar.bz2
gentoo-35c496ce213cb2c43c9621b060a58c2e8dcc7036.zip
dev-python/webassets: treeclean
Closes: https://bugs.gentoo.org/812380 Closes: https://bugs.gentoo.org/645726 Closes: https://bugs.gentoo.org/743971 Closes: https://bugs.gentoo.org/846482 Closes: https://bugs.gentoo.org/845906 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-python/webassets/Manifest1
-rw-r--r--dev-python/webassets/files/webassets-2.0-python39.patch23
-rw-r--r--dev-python/webassets/metadata.xml12
-rw-r--r--dev-python/webassets/webassets-2.0.ebuild46
-rw-r--r--profiles/package.mask1
5 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/webassets/Manifest b/dev-python/webassets/Manifest
deleted file mode 100644
index 0680de17ed94..000000000000
--- a/dev-python/webassets/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST webassets-2.0.tar.gz 185864 BLAKE2B 8aaa7091c27644c6c464d13d106218e28531415458e67696c0243943a92a3869e23c7ff0aa8461abb876a178e3ad44f4b47a5366edb885d308dd8ec0f17ad034 SHA512 6d62d4e5c1ed81a2d235c24776b632574f3670ae3d863c5f5a79d0e1afc7acfa7965e532b7975503df758dbe6c8dbd857b250a6ea8e4b414c8f1ae12fb8addd7
diff --git a/dev-python/webassets/files/webassets-2.0-python39.patch b/dev-python/webassets/files/webassets-2.0-python39.patch
deleted file mode 100644
index 006c020469f4..000000000000
--- a/dev-python/webassets/files/webassets-2.0-python39.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-https://github.com/miracle2k/webassets/commit/a563935df6702ff5e38e5b84a262c295e4cdf455.patch
-From a563935df6702ff5e38e5b84a262c295e4cdf455 Mon Sep 17 00:00:00 2001
-From: Karthikeyan Singaravelan <tir.karthi@gmail.com>
-Date: Wed, 22 Jan 2020 00:49:31 +0530
-Subject: [PATCH] Use is_alive instead of isAlive for Python 3.9 compatibility.
-
----
- tests/test_script.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/test_script.py b/tests/test_script.py
-index a83bc07f..d17a83bb 100644
---- a/tests/test_script.py
-+++ b/tests/test_script.py
-@@ -192,7 +192,7 @@ def start_watching(self):
-
- def stop_watching(self):
- """Stop the watch command thread."""
-- assert self.t.isAlive() # If it has already ended, something is wrong
-+ assert self.t.is_alive() # If it has already ended, something is wrong
- self.stopped = True
- self.t.join(1)
-
diff --git a/dev-python/webassets/metadata.xml b/dev-python/webassets/metadata.xml
deleted file mode 100644
index 8d3e20005efc..000000000000
--- a/dev-python/webassets/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="github">miracle2k/webassets</remote-id>
- <remote-id type="pypi">webassets</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/webassets/webassets-2.0.ebuild b/dev-python/webassets/webassets-2.0.ebuild
deleted file mode 100644
index 0f25c54ae40d..000000000000
--- a/dev-python/webassets/webassets-2.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Asset management for Python web development"
-HOMEPAGE="https://github.com/miracle2k/webassets"
-SRC_URI="https://github.com/miracle2k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# ^^ pypi tarball is missing tests
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-# dev-ruby/sass confuses the tests, they expect 'sass' as the reference
-# compiler
-BDEPEND="
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- !!dev-ruby/sass
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.0-python39.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # webassets wants /usr/bin/babel from babeljs,
- # but we have only one from openbabel
- # ... and we don't have postcss
- sed -i \
- -e 's|\(TestBabel\)|No\1|' \
- -e 's|\(TestAutoprefixer6Filter\)|No\1|' \
- tests/test_filters.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index b613e38b54f4..6fe01183159f 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -622,7 +622,6 @@ dev-python/pytest-salt
dev-python/requests_pkcs12
dev-python/slackclient
dev-python/tvdb_api
-dev-python/webassets
# Jonas Stein <jstein@gentoo.org> (2022-11-13)
# Dead upstream