summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 11:01:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 11:01:44 +0200
commit35d137c9dc218c00a51dafa4b07506b17047da85 (patch)
tree76178e160c4669a64afd0bba933f63d324bbb836
parentdev-python/zope-configuration: Bump to 4.4.1 (diff)
downloadgentoo-35d137c9dc218c00a51dafa4b07506b17047da85.tar.gz
gentoo-35d137c9dc218c00a51dafa4b07506b17047da85.tar.bz2
gentoo-35d137c9dc218c00a51dafa4b07506b17047da85.zip
dev-python/PyPDF2: Bump to 1.27.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyPDF2/Manifest1
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.27.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/Manifest b/dev-python/PyPDF2/Manifest
index 17400a1ebf43..54b8ee3a7029 100644
--- a/dev-python/PyPDF2/Manifest
+++ b/dev-python/PyPDF2/Manifest
@@ -1,2 +1,3 @@
DIST PyPDF2-1.26.0.tar.gz 77556 BLAKE2B 8ce9b95165a3841154b6e38e24ca5a4db434ceef9c55fbf2d146b379586160cb985948e0feb7aed135f601535d034ef79ddc1af58a670b07ff7d3621907022ec SHA512 7b427f1d099dcd687a718fb8d86e6f677ad45257414c6367e4dfacd8dfef7e3dbe3816027359868764981f36a30721f1731b4c23cbe2f35cfab1c64fb290b034
DIST PyPDF2-1.27.0.gh.tar.gz 1170298 BLAKE2B 465f24e149410ada5f5cc5f09c544357ff4871a1f1cf0036f88d8a2c1293e0ea548a5f55121672bb322c89fb5f18bb595d0226bd60427e939fbaf99dee0ee17a SHA512 13557809f1c80172c11e3984e4d4d6136b9f68e3e4610433e8a5cc2e0c67ac53361691a58c938d02d1a07402505aca8fad407bc548b15ab9b54fb06e111f4728
+DIST PyPDF2-1.27.1.gh.tar.gz 1170252 BLAKE2B 81049707d4dd406405ec994228226edfe7cde4d57007146893c5fec14a4e82355c427cac64a2e338945f06c5bce1802e64bf9b042770a2d2ea7da6ed6982908d SHA512 3bd00e7057af8d0f7fdea378b8fae463ce93d37c68997511df10c53b139c0cb13329143bdac133a825404ab459ab3ead64c455ac3e58ddd5097c2985f86c2a46
diff --git a/dev-python/PyPDF2/PyPDF2-1.27.1.ebuild b/dev-python/PyPDF2/PyPDF2-1.27.1.ebuild
new file mode 100644
index 000000000000..3b0208da7c61
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-1.27.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/PyPDF2/
+ https://github.com/py-pdf/PyPDF2/
+"
+SRC_URI="
+ https://github.com/py-pdf/PyPDF2/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r Sample_Code/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}