summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 12:52:20 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 12:54:54 +0100
commit35f0eb07a670cbbe8ac260b8f8d8895c88225f06 (patch)
treeb8e1113965ee9c9e5869bd750716712484ca24aa
parentdev-python/pdm-pep517: 1.0.6 requires <dev-python/packaging-22 (diff)
downloadgentoo-35f0eb07.tar.gz
gentoo-35f0eb07.tar.bz2
gentoo-35f0eb07.zip
dev-python/pbr: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-5.11.0.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 176c9088cc42..4b45e1658cfc 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,2 +1 @@
-DIST pbr-5.11.0.tar.gz 127505 BLAKE2B 201fcd04ded1f909f4792886ddf79a5a764318645ff6b6245543cde2940d502ab711820cb6e999894a339df933e43e6a8394bd8ec1e978d930710a3085b131fd SHA512 bdb442e8ef7bda90a65c5fb7f0696041808278fcc643eb0c15d5401b7da7d64cd3566018b1046145f55bc5683791ee182bec92461801004b02a35b8bf4c5abf0
DIST pbr-5.11.1.tar.gz 127597 BLAKE2B 4ed433f271b4cbed3e7baca66cbeef057d575b7b061507c45a65ba93704edbed7b6f8668e9b9766f03079aaf06dbd6c394960c1c528b1beb992db65d0c3b89e4 SHA512 466dc5ce2622c43451186698f00d405141878449ffe9f7771b0057e8356bf12b426a9bfefff7e5843f1b3f963af3ffc9c4a42fa91a9407b79617abea046ff438
diff --git a/dev-python/pbr/pbr-5.11.0.ebuild b/dev-python/pbr/pbr-5.11.0.ebuild
deleted file mode 100644
index 1ebeff6fa025..000000000000
--- a/dev-python/pbr/pbr-5.11.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( python3_{9..11} )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
-HOMEPAGE="
- https://opendev.org/openstack/pbr/
- https://github.com/openstack/pbr/
- https://pypi.org/project/pbr/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/setuptools-60.5.0[${PYTHON_USEDEP}]
-"
-# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
-# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
-# stestr is run as external tool
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
- dev-vcs/git
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests unittest
-
-python_prepare_all() {
- # TODO: investigate
- sed -e 's:test_console_script_develop:_&:' \
- -e 's:test_console_script_install:_&:' \
- -e 's:test_setup_py_keywords:_&:' \
- -i pbr/tests/test_core.py || die
- # network
- rm pbr/tests/test_wsgi.py || die
- # installs random packages via pip from the Internet
- sed -e 's:test_requirement_parsing:_&:' \
- -e 's:test_pep_517_support:_&:' \
- -i pbr/tests/test_packaging.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
- einfo "Testing on ${EPYTHON} is not supported at the moment"
- return
- fi
-
- eunittest -b
-}