summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-09 12:54:06 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-09 13:08:24 +0100
commit35ffe280aab872f2130714c651d0ec3f5a311cf4 (patch)
treeb822aa04fced5d64a85a98c44eea24f2caae2b60
parentdev-util/diffoscope: add Python 3.7 support (diff)
downloadgentoo-35ffe280.tar.gz
gentoo-35ffe280.tar.bz2
gentoo-35ffe280.zip
media-gfx/springgraph: Bump to EAPI 7
Closes: https://bugs.gentoo.org/697284 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--media-gfx/springgraph/springgraph-88.ebuild32
1 files changed, 14 insertions, 18 deletions
diff --git a/media-gfx/springgraph/springgraph-88.ebuild b/media-gfx/springgraph/springgraph-88.ebuild
index 31742ab52d12..eb82210357fa 100644
--- a/media-gfx/springgraph/springgraph-88.ebuild
+++ b/media-gfx/springgraph/springgraph-88.ebuild
@@ -1,39 +1,35 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils
-
-DESCRIPTION="Generate spring graphs from graphviz input files"
-HOMEPAGE="http://www.chaosreigns.com/code/springgraph"
MY_PV="0.${PV}"
MY_P="${PN}_${MY_PV}"
SRC_FILE="${MY_P}.orig.tar.gz"
SRC_DEBIAN_PATCH="${PN}_0.82-5.diff.gz"
+
+DESCRIPTION="Generate spring graphs from graphviz input files"
+HOMEPAGE="http://www.chaosreigns.com/code/springgraph"
SRC_URI="http://www.chaosreigns.com/code/springgraph/dl/${PN}.pl.${PV}
- mirror://debian/pool/main/${PN:0:1}/${PN}/${SRC_DEBIAN_PATCH}"
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${SRC_DEBIAN_PATCH}"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-DEPEND=""
+
RDEPEND="dev-perl/GD"
-S="${WORKDIR}/${PN}-${MY_PV}"
-src_unpack() {
- mkdir -p ${S}
- cp ${DISTDIR}/${PN}.pl.${PV} ${S}/${PN}
- EPATCH_OPTS="-p1 -d ${S}" epatch ${DISTDIR}/${SRC_DEBIAN_PATCH}
-}
+S=${WORKDIR}
+
+PATCHES=( "${SRC_DEBIAN_PATCH%.gz}" )
-src_compile() {
- # nothing to do
- :
+src_unpack() {
+ cp "${DISTDIR}"/${PN}.pl.${PV} ${PN} || die
+ default
}
src_install() {
- into /usr
dobin ${PN}
doman debian/${PN}.1
}