summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-05-04 12:52:41 -0400
committerLars Wendler <polynomial-c@gentoo.org>2019-05-06 09:34:51 +0200
commit361c925cafa7b21dfba3d6db7224da50ffda2ccc (patch)
tree901237d79124f3ac79a9caafbaf0a534816860aa
parentdev-libs/libbytesize: use python-r1 (diff)
downloadgentoo-361c925c.tar.gz
gentoo-361c925c.tar.bz2
gentoo-361c925c.zip
dev-libs/libbytesize: use the pre-prepared tarball
This avoids the need to autoreconf the sources. Package-Manager: Portage-2.3.62_p4, Repoman-2.3.12_p87 Signed-off-by: Mike Gilbert <floppym@gentoo.org> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/libbytesize/Manifest2
-rw-r--r--dev-libs/libbytesize/libbytesize-2.0-r3.ebuild (renamed from dev-libs/libbytesize/libbytesize-2.0-r2.ebuild)11
2 files changed, 4 insertions, 9 deletions
diff --git a/dev-libs/libbytesize/Manifest b/dev-libs/libbytesize/Manifest
index b1044dd8c458..aa6bbdb7f0e9 100644
--- a/dev-libs/libbytesize/Manifest
+++ b/dev-libs/libbytesize/Manifest
@@ -1,3 +1,3 @@
DIST libbytesize-1.2.tar.gz 70598 BLAKE2B e136b1274703da7b3596e7583cea1ac773c1594af09c626f4dbb481dfcc23a3186b03ebdc54bba67d0a063c5d6587f6b7f8b610828c461cfd114eea1388dd193 SHA512 a8151e7440d0ec43d10239ddf08a9924827cdf08f20a16dff6177b444c1022fab905a0567384531e7610d854998111adb77f9a6a98e2d9648c02521f84ea2bf2
DIST libbytesize-1.4.tar.gz 80943 BLAKE2B d4c6c34d81be01bf7db2c37b0660886d99eff3c0a87024f5fbc12cc3606dc01e772b81dfbcacbf76c62213120253a9e7bda90adbc749b6d4c3e31e1ed3ae7702 SHA512 5dd13cf52a1674be776220ee1863f42261a47dc53af1ce4a31460d6d02ce87e19c5a52260f700928af98f1d9d7a96de7c11d8f384907b3187ef2effc10cbb593
-DIST libbytesize-2.0.tar.gz 84673 BLAKE2B cbe439bafc5b6a5ee1fbba6ba3e78f6a2b080394eb1da57b14945edc9180cff179a0eafb9de29a9639dfcbd6abf86158aa84121b81704d9270a93e4331d98eea SHA512 5adc7f529bebab2a568b623f876c9b65e58cd1f19dcfb2cc0c068b03a4e0cbe6a527c9cef3417e442b5eb8c00c963f325090356474c69083793a55edb54a7001
+DIST libbytesize-2.0.tar.gz 440544 BLAKE2B a371c617c965171a8746339ff8a2ec412daf3f79ae80e4e6a404546b0fc2f59f3e5882fc93726701490ef267f90cfd8c5db70bf7bd334c08806ff35eaab97377 SHA512 9d2a18930d0d900262ced4abd5cd358896570eadb06435f1b9aba5484ca530478b65dfb4982e8acf77ca4519a2d8a1dc236d42f5fa1ecbd7461949b282ef44a1
diff --git a/dev-libs/libbytesize/libbytesize-2.0-r2.ebuild b/dev-libs/libbytesize/libbytesize-2.0-r3.ebuild
index bfb8a984b132..9dbadf259d2c 100644
--- a/dev-libs/libbytesize/libbytesize-2.0-r2.ebuild
+++ b/dev-libs/libbytesize/libbytesize-2.0-r3.ebuild
@@ -5,11 +5,11 @@ EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit autotools python-r1
+inherit python-r1
DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
HOMEPAGE="https://github.com/storaged-project/libbytesize"
-SRC_URI="https://github.com/storaged-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/storaged-project/libbytesize/releases/download/${PV}/${P}.tar.gz"
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
@@ -35,15 +35,10 @@ BDEPEND="
)
"
-DOCS=( NEWS.rst README.md )
+DOCS=( README.md )
RESTRICT="test"
-src_prepare() {
- default
- eautoreconf
-}
-
python_do() {
if use python; then
python_foreach_impl run_in_build_dir "$@"