summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2023-02-25 12:15:58 +0100
committerDaniel Pielmeier <billie@gentoo.org>2023-02-25 12:16:33 +0100
commit362bd94298b1236471c1d60b7f36ffd2d6cef065 (patch)
treef31818da1a71b3673688d51e62743783f5dfad7e
parentsys-kernel/vanilla-sources: add 6.2.1, drop 6.2.0 (diff)
downloadgentoo-362bd94298b1236471c1d60b7f36ffd2d6cef065.tar.gz
gentoo-362bd94298b1236471c1d60b7f36ffd2d6cef065.tar.bz2
gentoo-362bd94298b1236471c1d60b7f36ffd2d6cef065.zip
media-sound/puddletag: Add python 3.11 support.
Closes: https://bugs.gentoo.org/897038 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
-rw-r--r--media-sound/puddletag/puddletag-2.2.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/puddletag/puddletag-2.2.0-r1.ebuild b/media-sound/puddletag/puddletag-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..804e37ed485f
--- /dev/null
+++ b/media-sound/puddletag/puddletag-2.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9,10,11} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="Audio tag editor"
+HOMEPAGE="http://docs.puddletag.net/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acoustid quodlibet"
+
+DEPEND=""
+RDEPEND="
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.9[${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-5.15.7[${PYTHON_USEDEP},svg]
+ >=media-libs/mutagen-1.45.1[${PYTHON_USEDEP}]
+ acoustid? ( >=dev-python/pyacoustid-1.2.2-r1[${PYTHON_USEDEP}] )
+ quodlibet? ( >=media-sound/quodlibet-4.4.0[${PYTHON_USEDEP}] )
+ >=dev-python/PyQt5-sip-12.11.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.9.1[${PYTHON_USEDEP}]
+ >=dev-python/Levenshtein-0.18.1[${PYTHON_USEDEP}]
+"
+DOCS=(changelog NEWS THANKS TODO)