summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-06 15:02:16 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-06 15:05:44 +0100
commit362e272f9c54d31e2d3bb8063abed023d81f2a70 (patch)
tree497dd15bfb41562cdd46e1ebdf0d22791c984202
parentdev-db/mysql: Drop security vulnerable versions wrt bug 606254 (diff)
downloadgentoo-362e272f9c54d31e2d3bb8063abed023d81f2a70.tar.gz
gentoo-362e272f9c54d31e2d3bb8063abed023d81f2a70.tar.bz2
gentoo-362e272f9c54d31e2d3bb8063abed023d81f2a70.zip
dev-python/docker-py: Version bump to 2.0.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/docker-py/Manifest1
-rw-r--r--dev-python/docker-py/docker-py-2.0.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index 81c9d99200ff..374ab3eec5c3 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -1,3 +1,4 @@
DIST docker-py-1.10.6.tar.gz 122462 SHA256 dd1aa55dbe507538318e51e5303077d146d5176abd6b05fe9bcde24c289410bc SHA512 6360f9743472c42b3b080204195a0ba62ec85503cc3d4053dca1fb68e8dbed54bd90ed530d9b6ed0b29367aecbe3731d076c89e8d49365c133754bc38c3f15b9 WHIRLPOOL 3f42a0e597e63d0b821c1887b680b2faa8f696b65aa0851acaf00ccbc3ed2b271b1bbcc5390b99f6402b56f6a1a116fe76bf6a5f542b8beb9f8213e81df18f08
DIST docker-py-1.2.2.tar.gz 69685 SHA256 85284a5b1a965e01a5d0a91f9f639ad5069143a276c123198fdafc3659280b38 SHA512 bf00b19e0ab56e5c0e8459234d09722ca504ecd933bfba61cb4ab4805410f53f6ad6083f2e964ef5a6eded2ea05aa01a89c27621064386bae145c7258ed996ad WHIRLPOOL bd7ff4579f924e02d18581b1aca00790dcb84afda03e4cde70b349bfdb4ad43aa2e06da2bcbe780f6074d98f9af9b14fb9d2ab4da9265e56b73288902c9ede7a
DIST docker-py-2.0.1.tar.gz 160820 SHA256 21b37d9fb581bcf88fe5e38ed915a7e3d4bd94174ec45f654669d970da371801 SHA512 097956bbf67659702cc92762f1570c5f86c478f38c527974b9f2f9938e9baa9a8c97f0c3b5252343a92f036e0712dc09cbbc1c1d7fa893b194cef9ec02b37c5a WHIRLPOOL f3451f6a9ded054cd977c57e06608f891ad933af464254243df5be9d909883b11451620aab21e3acb535acb7aec13c077b0e62c7683166c4b4f170812e3b8759
+DIST docker-py-2.0.2.tar.gz 162030 SHA256 1d4a9f65c1e70aec5501c4d84486e3c0d9d0a0dbaa66b48e91f50a108a5c6b9c SHA512 9be455702e5dcf8d5e31fd204ea9b642a132876b1f758e7127daab56f0a8a9002af4b4fa39fd5bcf95208ade0a980d2f83bc81e9c5ba3ccdfaf5ae6ddedf4907 WHIRLPOOL 3ded3ed7177e4760566730e9fec31cde3fea25808b80b12a75294aad3648b13bf4df9ae42b5f5025376fcba022415179717664668ae9077ebb89406eefbba412
diff --git a/dev-python/docker-py/docker-py-2.0.2.ebuild b/dev-python/docker-py/docker-py-2.0.2.ebuild
new file mode 100644
index 000000000000..bc6e3e4830b8
--- /dev/null
+++ b/dev-python/docker-py/docker-py-2.0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/docker-pycreds-0.2.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed -i -e "s/import pip//" -e "s/if 'docker-py'.*/if False:/" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die "docs failed to build"
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}