summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-18 09:31:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-18 09:32:21 +0200
commit36339a3cadf1644313b2cd42f619f8ba8aba37dc (patch)
treecb041db423f8344d9e0d052c775cf7aa8b936f64
parentdev-python/pyh2o: Enable py3.13 (diff)
downloadgentoo-36339a3cadf1644313b2cd42f619f8ba8aba37dc.tar.gz
gentoo-36339a3cadf1644313b2cd42f619f8ba8aba37dc.tar.bz2
gentoo-36339a3cadf1644313b2cd42f619f8ba8aba37dc.zip
dev-python/pygments-ansi-color: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pygments-ansi-color/pygments-ansi-color-0.3.0.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/pygments-ansi-color/pygments-ansi-color-0.3.0.ebuild b/dev-python/pygments-ansi-color/pygments-ansi-color-0.3.0.ebuild
index 2b3a85b06cb4..116be4b6224c 100644
--- a/dev-python/pygments-ansi-color/pygments-ansi-color-0.3.0.ebuild
+++ b/dev-python/pygments-ansi-color/pygments-ansi-color-0.3.0.ebuild
@@ -1,22 +1,30 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
DESCRIPTION="ANSI color-code highlighting for Pygments"
-HOMEPAGE="https://pypi.org/project/pygments-ansi-color/"
+HOMEPAGE="
+ https://github.com/chriskuehl/pygments-ansi-color/
+ https://pypi.org/project/pygments-ansi-color/
+"
# No tests in PyPI tarballs
-SRC_URI="https://github.com/chriskuehl/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="
+ https://github.com/chriskuehl/pygments-ansi-color/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv"
-RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest