summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-09-09 15:04:36 +0200
committerTiziano Müller <dev-zero@gentoo.org>2016-09-09 15:05:20 +0200
commit363985f5ea600f8d1e0a0e8ff380518d5d51bf7e (patch)
treeb0d6907f08ad18f1cdf5225e2963a00d696be05e
parentadd new Skype TOS (diff)
downloadgentoo-363985f5ea600f8d1e0a0e8ff380518d5d51bf7e.tar.gz
gentoo-363985f5ea600f8d1e0a0e8ff380518d5d51bf7e.tar.bz2
gentoo-363985f5ea600f8d1e0a0e8ff380518d5d51bf7e.zip
dev-python/pyhamcrest: version bump (including EAPI 6 bump and py-3.5 support)
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/pyhamcrest/Manifest1
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index 2413ce8ac5b1..c24570be137d 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1,3 +1,4 @@
DIST PyHamcrest-1.8.2.tar.gz 372308 SHA256 bd14093c561f9af8ce8271a630929f4a45be7a4e79bec53c83b876a0547d303e SHA512 ff90a6bb1e2319d25ba8c29e998796544d5840599e7d9a4a178022e6b5bcabd23d35433073152a2707d555aab3aa96c316b8db54d7ec1c0ca2ef1cdf50e4df40 WHIRLPOOL e207d109420ea3d1eb6cf14c65a3d2eb9e1dcabcc30b7917f4c95cb445a554c2fea8e5766213fd513c9323c33b58a63f0d9b102b52062ed7f61b148aeba3c770
DIST PyHamcrest-1.8.3.tar.gz 376145 SHA256 118c48351451ec027cceed781841c19b836739e21f71a26649fe97fca0d346d5 SHA512 4e11a3ca93886c58b512b5ad77f95c2df3771476d6ca0e99eb6e20c0292819a5f985b7004b3523c756255e503cfe4e266fdb776b285e430a7bd987164f9df14a WHIRLPOOL 4210a503b5eb1f60e7f6757d21b0887f96cfe8b5f261d490f5589d3bbd0e099b91d1dd0264025e3730c94b78419cc8e762e66ded8e33dba3b37dc3764beba4ea
DIST PyHamcrest-1.8.5.tar.gz 376456 SHA256 db990f17477bb0e78f726e8b04fe3ac78f697011e5c8ecb0928567db14efca55 SHA512 7841f704fdad8653bad923dc243431b4c3d82a9646d1138528356162bd556bc5d16178fbc6b1f27918e8ac1df6c54afb4d5eb8b3286536df33dd85ace475ea2d WHIRLPOOL 721fd1101a32b44bfd1cc8e8fc5e63a776ce5c5b3e126311f7f185cee092ebe6035151737db1b99edeca0e9d395a4eb1c1811a83aaed015be4dc6ce2499609f3
+DIST PyHamcrest-1.9.0.tar.gz 376623 SHA256 8ffaa0a53da57e89de14ced7185ac746227a8894dbd5a3c718bf05ddbd1d56cd SHA512 3b8393d0079b619b208ec7f06ed5133c4ff9d9dba050f818adf56347fc2225fd1c85d60f3dc262b7b9722061f0b8e4966180b6b96245a371e578d0d51633b4b0 WHIRLPOOL 2fcd5a30131c7bdf87fe79640d2eee9b4c773be9a25fd79fc8b82d8915d5cd00c6c574b02224e8a2b83cf1590d69884d15c5d300e053b8edcf9468fbe03861a5
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild
new file mode 100644
index 000000000000..0e087fe27290
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MY_PN="PyHamcrest"
+
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.6[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RESTRICT="test"
+# the pypi tarball is missing the tests
+# and the 1.9.0 tag is missing in GitHub
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+ "${PYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}