summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-05 18:27:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-07 15:25:16 +0100
commit363a6e90444e0844804ca5baee960955a94aebe7 (patch)
treeaa143d17dbb4b52ffc8fb8a749941a61ccd3c599
parentpypi.eclass: Support --unpack in pypi_wheel_url (diff)
downloadgentoo-363a6e90444e0844804ca5baee960955a94aebe7.tar.gz
gentoo-363a6e90444e0844804ca5baee960955a94aebe7.tar.bz2
gentoo-363a6e90444e0844804ca5baee960955a94aebe7.zip
dev-python/installer: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/installer/installer-0.6.0.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/installer/installer-0.6.0.ebuild b/dev-python/installer/installer-0.6.0.ebuild
index 5310b5520a29..fcb3784df3fd 100644
--- a/dev-python/installer/installer-0.6.0.ebuild
+++ b/dev-python/installer/installer-0.6.0.ebuild
@@ -7,7 +7,7 @@ EAPI=7
DISTUTILS_USE_PEP517=no
PYTHON_COMPAT=( python3_{9..11} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="A library for installing Python wheels"
HOMEPAGE="
@@ -18,8 +18,7 @@ HOMEPAGE="
SRC_URI="
https://github.com/pypa/installer/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
- https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P%_p*}-py3-none-any.whl
- -> ${P%_p*}-py3-none-any.whl.zip
+ $(pypi_wheel_url --unpack)
"
LICENSE="MIT"