summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-10 09:06:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-10 09:34:12 +0200
commit363ab463c80642621d551189fff146b29dc4a767 (patch)
tree11b4407bc7efd5194968cf2c48123ed189b97c26
parentdev-python/dask: Bump to 2021.7.0 (diff)
downloadgentoo-363ab463c80642621d551189fff146b29dc4a767.tar.gz
gentoo-363ab463c80642621d551189fff146b29dc4a767.tar.bz2
gentoo-363ab463c80642621d551189fff146b29dc4a767.zip
dev-python/google-api-core: Bump to 1.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-1.31.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index fc7c8a2f70ec..467a2ccf772e 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,2 +1,3 @@
DIST google-api-core-1.28.0.tar.gz 133640 BLAKE2B 8134e39cc3ff2fbb850d5e774d08589e3e64b83ca5d5209279f5d1b7fc2eb350a523bbe2890fba6d907689149df3872a7e0a11991b1ecc62fc64a4753dce38e4 SHA512 3702d27613e621394209047451729c1308beb88c917033b4340e3fa96bf4a5ec36ad2594c98ed14439c578f69a202d95a96d30472438a30417484cff6e06fe7d
DIST google-api-core-1.30.0.tar.gz 134595 BLAKE2B 104f52bafb68fd91904c02cbd6d3dd2e32c160a528f58e9af3612fc4f7a9934c522f79895b50982b46ee77947af7eb52557bf304b6f2624b97b5082905511829 SHA512 cc14f9c67bac99290665e2b85a97eacf43cdd2a0e4668ecbc7dd8e7131a7e4e908aca2be6d65797d0838081a02768354703762a1a80fa0b666efb81448b27899
+DIST google-api-core-1.31.0.tar.gz 134806 BLAKE2B 8609dd1260b72bc2c8fe949625c1b592e409bcd34c90f46671ef5c1573775f1957723ab6a03909b55145370e2c06250717b15452a89400ad1b6273a28c5a98a3 SHA512 af5a134ffeb65358d1b8e39bc6b0fe0b5477572dc915d941d63fcfeea72cff46c74d5d85350417484243a298462ab1322f69657694b25472d023db4b5fb27659
diff --git a/dev-python/google-api-core/google-api-core-1.31.0.ebuild b/dev-python/google-api-core/google-api-core-1.31.0.ebuild
new file mode 100644
index 000000000000..e85bbb95287c
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-1.31.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core
+ https://googleapis.dev/python/google-api-core/latest"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}