summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-08 06:24:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-08 07:34:45 +0200
commit363c1a803a61cbe43cd8c1d2baed0d497af66289 (patch)
tree808a48223f1a359cf42dedfc7b199163645faed3
parentapp-admin/awscli: Bump to 1.25.4 (diff)
downloadgentoo-363c1a80.tar.gz
gentoo-363c1a80.tar.bz2
gentoo-363c1a80.zip
dev-python/google-auth: Bump to 2.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.7.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 164ecf6ab578..54091bdbb377 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1 +1,2 @@
DIST google-auth-2.6.6.tar.gz 189789 BLAKE2B 8adf725ac8678a07c6c35f641950c5da0f269e8556074b5832a08267cbb64237dda817c576b15fbb315fd0a018e30bca1fa1f5a0d1f85aaae4ab2bd58538b191 SHA512 bac6345bf142a8dc6acde0bec43a8fd78f76277740114a0557af88748a5ec2f509757e6099f570ed037b2265717f339fe319254a826793d0b16f1a7d227a6b09
+DIST google-auth-2.7.0.tar.gz 195638 BLAKE2B 487047f75c3fabde929a451d009ebfcb89ef816cad07cd6fda7b436c69f6eedee6dad64780df743ea133b66aab72f75f0185263fd542eb1475d642d7a6e2e2b9 SHA512 ba506619b1392dcd85b71f9ea68dd3acadcb93c4017030d2d812d383c971e6917ed074e64b9a554db9879d61b229a1d35a041c487a517113652934a6849122e5
diff --git a/dev-python/google-auth/google-auth-2.7.0.ebuild b/dev-python/google-auth/google-auth-2.7.0.ebuild
new file mode 100644
index 000000000000..de5188c8fdb8
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}