summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-06 21:31:25 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-06 21:31:32 +0200
commit365bb0e478571800de5797c33b8af4c048f778ad (patch)
tree74e8a99b335a293f1eece1ea35b8ddea6ac80f4b
parentsys-devel/binutils: use simpler shell test (diff)
downloadgentoo-365bb0e4.tar.gz
gentoo-365bb0e4.tar.bz2
gentoo-365bb0e4.zip
dev-python/google-api-python-client: add 2.34.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.34.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index b00e95b986df..fbc7cca3e561 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1 +1,2 @@
DIST google-api-python-client-2.33.0.tar.gz 28292803 BLAKE2B b7e285a78d06aa9c0cb5609521443aa048220bb4b83e900b5915603c3cc1bd2eb6ff009c43503a8178f4ca2281fed0488bae9fbe0c29bf7a9df9ac2d4cf294e4 SHA512 47c8352440a2ffd3beca049a200c4a0cb1a2299b5fbce70b64a913f6121e731325831b229102d9940b386e082592efd49fdfc9409055b32f172551862740bd63
+DIST google-api-python-client-2.34.0.tar.gz 28469433 BLAKE2B aa2c8849b629fe489cf39cddd410a40a0af0bddfa5f370a4a41c1446aeadf69cd4592eeb1d76e6c63da9737906801aea9c8a4d706328b63a7bf5b34a43b83e00 SHA512 321dfdd3ba821beabc6c3a96575afd06c75a0c8e3db61b1ff5fa9db472e62de81b037c435a1051d6294c2a37e471bcaa068cd27ad7434a3416231d31931dd74e
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.34.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.34.0.ebuild
new file mode 100644
index 000000000000..b7db8f42faf4
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.34.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest tests
+}