summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:44:41 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:44:41 -0600
commit366427976a501f4fbc2c7e3a48891b8cf4e10c28 (patch)
treecb9d74d800afaad5d4686d40ff94c50b0e7503f1
parentdev-python/glance_store: bup (diff)
downloadgentoo-36642797.tar.gz
gentoo-36642797.tar.bz2
gentoo-36642797.zip
dev-python/semantic_version: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/semantic_version/Manifest1
-rw-r--r--dev-python/semantic_version/semantic_version-2.6.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/semantic_version/Manifest b/dev-python/semantic_version/Manifest
index 89da8b1ef934..5ae44e5b5cec 100644
--- a/dev-python/semantic_version/Manifest
+++ b/dev-python/semantic_version/Manifest
@@ -1 +1,2 @@
DIST semantic_version-2.4.2.tar.gz 30711 SHA256 7e8b7fa74a3bc9b6e90b15b83b9bc2377c78eaeae3447516425f475d5d6932d2 SHA512 485eb478645141999f9f4f807b7c001c7a9a11d46cc100d897df6f5cb1e7653faca4aca32c7c248bc8bcc543d233ae2a3897af11d8a05a2c5881cc7d267bc356 WHIRLPOOL 9721b86e5d6cc378a2ceaa0cca600e329bf1cdd14cfc524f730712effea6862d01de76dcce4d607eb19b99067f04fb07f73004637860c0324371caa57190f898
+DIST semantic_version-2.6.0.tar.gz 13919 SHA256 2a4328680073e9b243667b201119772aefc5fc63ae32398d6afafff07c4f54c0 SHA512 805449e7219aaa59d28cc267c27a6abab5cbbbfd52c72d66f24bcace39c9f864e4ed944a3dc614e14a700a5bc92272fa6420312f3169b01a4cfd9ddf3ffb42d6 WHIRLPOOL 293dec8e54ea1214891642e87972955f41286f1d4ef76f59a62a00996588a43aadfec893f451aa1733186f4d76ca67a2efe496f2f20412359c08fb11d5de1206
diff --git a/dev-python/semantic_version/semantic_version-2.6.0.ebuild b/dev-python/semantic_version/semantic_version-2.6.0.ebuild
new file mode 100644
index 000000000000..3a703983e9f0
--- /dev/null
+++ b/dev-python/semantic_version/semantic_version-2.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library providing a few tools handling SemVer in Python."
+HOMEPAGE="https://pypi.python.org/pypi/semantic_version"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ esetup.py test
+}