summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-24 05:46:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-24 08:00:52 +0200
commit366987a4aaa39adc4c7f0b36b900e2e70e9a1017 (patch)
tree2dbd63121e47746f0df6ddca7aa73425e5b35fd8
parentdev-python/botocore: Bump to 1.26.6 (diff)
downloadgentoo-366987a4aaa39adc4c7f0b36b900e2e70e9a1017.tar.gz
gentoo-366987a4aaa39adc4c7f0b36b900e2e70e9a1017.tar.bz2
gentoo-366987a4aaa39adc4c7f0b36b900e2e70e9a1017.zip
dev-python/boto3: Bump to 1.23.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.23.6.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index d78d2c9a7ee5..280ddb111846 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.23.2.tar.gz 500287 BLAKE2B b997f18cfb2b5c03eab7decd14a60d70546eb60f
DIST boto3-1.23.3.tar.gz 501196 BLAKE2B 8fbe6ec091e249bf675b9245a3ad73416bfae77de8c197f6b5bc6d919e7082aa36b53a93034d5658d7f27c928c932b0f077fc9beea6bbc9015c26e925cc565c2 SHA512 96fa0382a4841901eb961a1135799823710af24c236c4be6def180597bdb53a852fa2c0ea34cf6d1b8cfba0e5c5a2b10f361677a993b733bc14729ee68af16f2
DIST boto3-1.23.4.tar.gz 501445 BLAKE2B f38c963558c99fade5b55c0b8d96221de7af7a215f7be2a4863285152720318f05cbaf996f8f0910f68830fdbb214b242d2e8e2e538ae345e4877a0ed733c148 SHA512 85298ddbb4a305354c50f4f63e9e6d0a1c821ac18e15dfaaf3d8ea3e03fd86fb6ea913402c6ac5cde4305895f387cf25eca928b7f00403198ad2eb5efe965eb7
DIST boto3-1.23.5.tar.gz 501625 BLAKE2B 5a996b4dffd325ea2d6582450b027767ca9845e8096193ef4a8a63ecd61999c67a83cc3b5bc4e77d1f50035188f97003942f1b64293adb36a9cd6e71781b2279 SHA512 5496de026313e9a767f3ba42fe903093ce69777627835a00d75dac4aa966c803a46682b4d766002af793c7e8c95be141cd0d0bbbf27961bd020ac18ef64f5175
+DIST boto3-1.23.6.tar.gz 502243 BLAKE2B d5b20d24d76df16669de25bdd9486766e4c4983f2619b9690a1bb318172d3343ae67cc9746438964817c60b1a2e7b3cb530f0dc54e15c13fe14c8cd1a566875b SHA512 3f940e394a15d10593b23ad67ffa16c9a45bbc5d6231b9ae621f90af3bc3497173f309191af7f3d9c3d4ea0331109228853c08d3fed7a84226481a8d911837ed
diff --git a/dev-python/boto3/boto3-1.23.6.ebuild b/dev-python/boto3/boto3-1.23.6.ebuild
new file mode 100644
index 000000000000..8b87bf9ae488
--- /dev/null
+++ b/dev-python/boto3/boto3-1.23.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}