summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-04-09 00:16:15 -0400
committerSam James <sam@gentoo.org>2024-04-09 15:43:29 +0100
commit36743b3902395fde41a127aabdcb6e3d911ddaf1 (patch)
tree0f6aa38eb7c1ab5c5cf9f97b12eb8aa93b4c69c5
parentmedia-libs/libjxl: drop outdated LTO-unsafety workaround (diff)
downloadgentoo-36743b3902395fde41a127aabdcb6e3d911ddaf1.tar.gz
gentoo-36743b3902395fde41a127aabdcb6e3d911ddaf1.tar.bz2
gentoo-36743b3902395fde41a127aabdcb6e3d911ddaf1.zip
media-libs/openpgl: mark as LTO-unsafe, strict-aliasing unsafe
Note: Upstream updating to set -fno-strict-aliasing is not the same as fixing the issue. Closes: https://bugs.gentoo.org/926890 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/openpgl/openpgl-0.5.0-r1.ebuild7
-rw-r--r--media-libs/openpgl/openpgl-0.6.0.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/media-libs/openpgl/openpgl-0.5.0-r1.ebuild b/media-libs/openpgl/openpgl-0.5.0-r1.ebuild
index 79487e34b3a1..75a81e52b091 100644
--- a/media-libs/openpgl/openpgl-0.5.0-r1.ebuild
+++ b/media-libs/openpgl/openpgl-0.5.0-r1.ebuild
@@ -29,6 +29,13 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/926890
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DOPENPGL_ISA_SSE4="$(usex cpu_flags_x86_sse4_2)"
-DOPENPGL_ISA_AVX2="$(usex cpu_flags_x86_avx2)"
diff --git a/media-libs/openpgl/openpgl-0.6.0.ebuild b/media-libs/openpgl/openpgl-0.6.0.ebuild
index 79487e34b3a1..07d8adf9d845 100644
--- a/media-libs/openpgl/openpgl-0.6.0.ebuild
+++ b/media-libs/openpgl/openpgl-0.6.0.ebuild
@@ -29,6 +29,13 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/926890
+ #
+ # Upstream "solved" this by setting -fno-strict-aliasing themselves.
+ # Do not trust with LTO.
+ filter-lto
+
local mycmakeargs=(
-DOPENPGL_ISA_SSE4="$(usex cpu_flags_x86_sse4_2)"
-DOPENPGL_ISA_AVX2="$(usex cpu_flags_x86_avx2)"