summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-05-01 10:24:04 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-05-01 10:24:21 +0200
commit367d98896ed2931fc2573fc4e7728e30a9be1105 (patch)
tree17b461a949dcc0b320fa4c4cb834c558fb410c48
parentdev-perl/Perl-Critic: add dev-perl/Pod-Parser dep for Pod-PlainText (diff)
downloadgentoo-367d98896ed2931fc2573fc4e7728e30a9be1105.tar.gz
gentoo-367d98896ed2931fc2573fc4e7728e30a9be1105.tar.bz2
gentoo-367d98896ed2931fc2573fc4e7728e30a9be1105.zip
media-sound/fluidsynth: dropped obsolete 2.3.4-r1
Bug: https://bugs.gentoo.org/930968 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/fluidsynth/Manifest1
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild149
2 files changed, 0 insertions, 150 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index bd4300bedcf9..7436af626a1a 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,2 +1 @@
-DIST fluidsynth-2.3.4.tar.gz 1775291 BLAKE2B 5146c1f0243ac1fcc3d4f29ea65bb03b326c59bf9de1f53def447f4a924c7fdde31f8b33300051d2e7765087fb8bbdba3643b03c537e3366b02ca42b3b9d4311 SHA512 79891116d78b9be1c38bce9e5759b9bb732c3d8ee31c6e57d1a3e2b5548879b91d19582e73ee7fb0fd243beba3bf1bbc341a26aab0b6440eef36fc55dce3e8b0
DIST fluidsynth-2.3.5.tar.gz 1775448 BLAKE2B 11f04d2a508f54c4bd03c867e81528f36eeb5698ad017d7fe778349b5ab91dc9e518d426d2394e748344795b8c1bf86eeaee97294ad66974db07587d0a80797a SHA512 35eaea8c1709ebbd5dee8f3946ab59c39afe31d92b972a44013fa23987aa48936f7d1326d5bda81c6e66f02bf988e48601367d49276a4dd78dbca7a2571f5e57
diff --git a/media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild b/media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild
deleted file mode 100644
index 936c864a0e52..000000000000
--- a/media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib multibuild systemd toolchain-funcs
-
-DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
-HOMEPAGE="https://www.fluidsynth.org"
-SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0/3"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86"
-IUSE="alsa dbus debug doc ipv6 jack ladspa lash network oss pipewire portaudio pulseaudio +readline sdl +sndfile systemd threads"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- app-text/doxygen
- dev-libs/libxslt
- )
-"
-DEPEND="
- dev-libs/glib:2[${MULTILIB_USEDEP}]
- alsa? (
- media-libs/alsa-lib[${MULTILIB_USEDEP}]
- lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
- )
- dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
- jack? ( virtual/jack[${MULTILIB_USEDEP}] )
- ladspa? (
- media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
- media-plugins/cmt-plugins[${MULTILIB_USEDEP}]
- )
- pipewire? (
- media-video/pipewire:0=[${MULTILIB_USEDEP}]
- )
- portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
- pulseaudio? ( media-libs/libpulse[${MULTILIB_USEDEP}] )
- readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
- sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
- sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
-
-src_prepare() {
- # https://bugs.gentoo.org/833979#c17
- sed -i "/CONFIGURE_COMMAND/{n;s/$/ -DCMAKE_C_COMPILER=$(tc-getBUILD_CC)/}" \
- src/CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -Denable-alsa=$(usex alsa)
- -Denable-aufile=ON
- -Denable-dbus=$(usex dbus)
- -Denable-dsound=OFF # Windows
- -Denable-floats=OFF # loat instead of double for DSP samples
- -Denable-fpe-check=$(usex debug)
- -Denable-ipv6=$(usex ipv6)
- -Denable-jack=$(usex jack)
- -Denable-ladspa=$(usex ladspa)
- -Denable-libinstpatch=OFF # https://github.com/swami/libinstpatch
- -Denable-midishare=OFF # http://midishare.sourceforge.net/
- -Denable-network=$(usex network)
- -Denable-opensles=OFF
- -Denable-oboe=OFF # requires OpenSLES and/or AAudio
- -Denable-oss=$(usex oss)
- -Denable-libsndfile=$(usex sndfile)
- -Denable-portaudio=$(usex portaudio)
- -Denable-profiling=$(usex debug)
- -Denable-pulseaudio=$(usex pulseaudio)
- -Denable-pipewire=$(usex pipewire)
- -Denable-readline=$(usex readline)
- -Denable-sdl2=$(usex sdl)
- -Denable-systemd=$(usex systemd)
- -Denable-threads=$(usex threads)
- -Denable-trap-on-fpe=$(usex debug)
- -Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
- -Denable-waveout=OFF # Windows
- -Denable-winmidi=OFF # Windows
- $(cmake_use_find_package doc Doxygen)
- )
-
- if use alsa; then
- mycmakeargs+=( -Denable-lash=$(usex lash) )
- else
- mycmakeargs+=( -Denable-lash=OFF )
- fi
-
- if use systemd; then
- mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
- fi
-
- cmake-multilib_src_configure
-}
-
-compile_doxygen_doc() {
- multilib_is_native_abi && cmake_build doxygen
-}
-
-src_compile() {
- cmake-multilib_src_compile
- use doc && multilib_foreach_abi compile_doxygen_doc
-}
-
-install_doxygen_doc() {
- if multilib_is_native_abi; then
- docinto .
- dodoc -r "${BUILD_DIR}/doc/api/html"
- fi
-}
-
-install_systemd_files() {
- if multilib_is_native_abi; then
- systemd_dounit "${BUILD_DIR}/fluidsynth.service"
- insinto /etc
- doins "${BUILD_DIR}/fluidsynth.conf"
- fi
-}
-
-multilib_src_test() {
- eninja check
-}
-
-src_install() {
- cmake-multilib_src_install
-
- docinto pdf
- dodoc doc/*.pdf
-
- docinto examples
- dodoc doc/examples/*.c
-
- if use doc; then
- multilib_foreach_abi install_doxygen_doc
- fi
- if use systemd; then
- multilib_foreach_abi install_systemd_files
-
- elog "When using fluidsynth as a systemd service, make sure"
- elog "to configure your fluidsynth settings globally in "
- elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
- fi
-}